Bug 174480 - Eliminate reflection to Felix
Eliminate reflection to Felix
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Netigso
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 17:47 UTC by Jaroslav Tulach
Modified: 2010-01-24 08:47 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments
Patch that relies on changes to be integrated by Richard Hall (in 2.1?) (6.01 KB, patch)
2009-10-13 17:48 UTC, Jaroslav Tulach
Details | Diff
Updated patch to core.netigso as it is integrated to trunk (6.37 KB, patch)
2010-01-15 02:13 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2009-10-13 17:47:44 UTC
Currently Netigso is using reflection to convince Felix to do the classloading the way Netigso needs. It would be nice 
to eliminate this.
Comment 1 Jaroslav Tulach 2009-10-13 17:48:47 UTC
Created attachment 89388 [details]
Patch that relies on changes to be integrated by Richard Hall (in 2.1?)
Comment 2 Jaroslav Tulach 2010-01-15 02:13:04 UTC
Created attachment 93305 [details]
Updated patch to core.netigso as it is integrated to trunk
Comment 3 Jaroslav Tulach 2010-01-21 23:21:04 UTC
core-main#9ce8df855df0

As soon as official release 2.0.3 is out, we shall upgrade the binary. Otherwise the issue is fixed.
Comment 4 Quality Engineering 2010-01-24 08:47:40 UTC
Integrated into 'main-golden', will be available in build *201001240200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9ce8df855df0
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: Merge of #174480: Eliminating reflection to Felix and replacing it with friend contract provided by Felix based on Map<Bundle,ClassLoader>


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo