Bug 174450 - [68cat] java.util.ConcurrentModificationException at java.util.AbstractList$Itr.checkForComodification
[68cat] java.util.ConcurrentModificationException at java.util.AbstractList$I...
Status: RESOLVED FIXED
Product: xml
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 7.2
Assigned To: Svata Dedic
issues@xml
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 199666 213390 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 14:34 UTC by giorgio42
Modified: 2012-10-30 16:07 UTC (History)
17 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.30 KB, text/plain)
2009-10-13 14:34 UTC, giorgio42
Details
stacktrace (2.30 KB, text/plain)
2009-12-01 03:21 UTC, Eduardo.m Costa
Details
stacktrace (1007 bytes, text/plain)
2010-01-18 10:01 UTC, Exceptions Reporter
Details
stacktrace (2.19 KB, text/plain)
2011-03-23 21:06 UTC, Jesse Glick
Details
stacktrace (1008 bytes, text/plain)
2012-01-26 08:46 UTC, jmborer
Details
stacktrace (2.21 KB, text/plain)
2012-01-28 09:16 UTC, Maksim Khramov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giorgio42 2009-10-13 14:34:18 UTC
Build: NetBeans IDE 6.8 M2 (Build 200910071658)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments:
giorgio42: Tried to open the file log4j.xml in WEB-INF/classes in a standard servlet 2.4 web application.



Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
        at java.util.AbstractList$Itr.next(AbstractList.java:343)
        at org.netbeans.modules.xml.sync.DataObjectSyncSupport.addRepresentation(DataObjectSyncSupport.java:137)
        at org.netbeans.modules.xml.text.TextEditorSupport$3.stateChanged(TextEditorSupport.java:201)
        at org.openide.text.CloneableEditorSupport.fireStateChangeEvent(CloneableEditorSupport.java:2297)
        at org.openide.text.CloneableEditorSupport.fireDocumentChange(CloneableEditorSupport.java:2280)
Comment 1 giorgio42 2009-10-13 14:34:22 UTC
Created attachment 89370 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-11-30 10:11:57 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157802
Comment 3 Eduardo.m Costa 2009-12-01 03:21:21 UTC
Created attachment 91905 [details]
stacktrace
Comment 4 Exceptions Reporter 2010-01-18 10:01:42 UTC
Created attachment 93387 [details]
stacktrace
Comment 5 Exceptions Reporter 2010-05-25 06:32:26 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157802
Comment 6 Jesse Glick 2011-03-23 21:06:57 UTC
Created attachment 107228 [details]
stacktrace
Comment 7 jmborer 2012-01-26 08:46:07 UTC
Created attachment 115261 [details]
stacktrace

Occured while moving a panel in the form editor
Comment 8 Maksim Khramov 2012-01-28 09:16:13 UTC
Created attachment 115338 [details]
stacktrace
Comment 9 Exceptions Reporter 2012-02-22 10:11:00 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157802
Comment 10 Svata Dedic 2012-03-15 09:00:09 UTC
*** Bug 199666 has been marked as a duplicate of this bug. ***
Comment 11 Svata Dedic 2012-03-19 14:09:47 UTC
Changeset: ca0b2fa30781
Author:    Svata Dedic <sdedic@netbeans.org>
Date:      2012-03-19 15:09
Message:   Issue #174450 - [68cat] java.util.ConcurrentModificationException at java.util.AbstractList$Itr.checkForComodification: fixed
Synchronzization added
Comment 12 Quality Engineering 2012-03-20 12:52:28 UTC
Integrated into 'main-golden', will be available in build *201203200400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ca0b2fa30781
User: Svata Dedic <sdedic@netbeans.org>
Log: Issue #174450 - [68cat] java.util.ConcurrentModificationException at java.util.AbstractList$Itr.checkForComodification: fixed
Synchronzization added
Comment 13 Svata Dedic 2012-10-30 16:07:54 UTC
*** Bug 213390 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo