Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 174278 - AWT thread blocked for 5513 ms.
AWT thread blocked for 5513 ms.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Palette
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-10 08:23 UTC by abien
Modified: 2009-10-15 10:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (46.84 KB, bin/nps)
2009-10-10 08:23 UTC, abien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abien 2009-10-10 08:23:11 UTC
This issue was originally marked as duplicate of issue 172715, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE 6.8 M2 (Build 200910071658)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.1-b02-90, Java(TM) SE Runtime Environment, 1.6.0_15-b03-219
OS: Mac OS X, 10.6.1, x86_64

User Comments:
abien: NetBeans 6.8 m2 reported "slowness" by opening 2 small maven projects (during startup)


Maximum slowness yet reported was 5513 ms, average is 5513
Comment 1 abien 2009-10-10 08:23:16 UTC
Created attachment 89250 [details]
nps snapshot
Comment 2 Stanislav Aubrecht 2009-10-12 10:02:03 UTC
fixed

core-main 1a27a6bda8ab
Comment 3 Quality Engineering 2009-10-15 10:28:08 UTC
Integrated into 'main-golden', will be available in build *200910150201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1a27a6bda8ab
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #174278 - don't load palette content in AWT thread


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo