Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 174198 - GsfReformatTask.reformat in AWT
GsfReformatTask.reformat in AWT
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 167997 176691 178105 178522 (view as bug list)
Depends on: 170882
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-09 10:45 UTC by rmatous
Modified: 2010-05-13 09:17 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread (4.15 KB, text/plain)
2009-10-09 10:46 UTC, rmatous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rmatous 2009-10-09 10:45:40 UTC
WARNING [org.netbeans.modules.parsing.impl.TaskProcessor]: ParserManager.parse called in AWT event thread by:
org.netbeans.modules.csl.core.GsfReformatTask.reformat(GsfReformatTask.java
Comment 1 rmatous 2009-10-09 10:46:39 UTC
Created attachment 89173 [details]
thread
Comment 2 Petr Hejl 2009-10-09 10:49:04 UTC
*** Issue 167997 has been marked as a duplicate of this issue. ***
Comment 3 Vitezslav Stejskal 2009-10-09 11:10:58 UTC
Not sure how to avoid this.
Comment 4 rmatous 2009-10-09 13:27:11 UTC
P2 really: attempt to reformat code during scanning => long term freeze
Comment 5 mslama 2009-10-12 11:26:04 UTC
There should be unified UI approach for such synchronous actions performed in AWT.
Comment 6 mslama 2009-10-13 13:59:08 UTC
It should be fixed in actions.
Comment 7 Vitezslav Stejskal 2009-11-03 14:22:05 UTC
http://hg.netbeans.org/jet-main/rev/2cc2297b8931
Comment 8 Quality Engineering 2009-11-05 10:18:46 UTC
Integrated into 'main-golden', will be available in build *200911050201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2cc2297b8931
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #174198: using runOffEDT in FormatAction
Comment 9 Vitezslav Stejskal 2009-11-13 05:43:08 UTC
*** Bug 176691 has been marked as a duplicate of this bug. ***
Comment 10 Vitezslav Stejskal 2009-12-03 23:33:47 UTC
*** Bug 178105 has been marked as a duplicate of this bug. ***
Comment 11 Jan Lahoda 2010-05-13 09:17:48 UTC
*** Bug 178522 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo