Bug 174048 - Problems installing plugins due to "The module named ... was needed and not found." error
Problems installing plugins due to "The module named ... was needed and not f...
Status: RESOLVED DUPLICATE of bug 175196
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All Linux
: P2 (vote)
: TBD
Assigned To: dlipin
issues@platform
:
: 156766 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-08 09:43 UTC by Michael Nazarov
Modified: 2009-10-30 11:16 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
logs (15.53 KB, application/x-gzip)
2009-10-22 10:38 UTC, Michael Nazarov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nazarov 2009-10-08 09:43:49 UTC
Steps to reproduce:

1. Install full M2.
2. Install all available plugins.
3. Restart IDE.

Followed message will appear:

Warning - could not install some modules: Code Coverage Plugin - The module named com.vladium.emma/1 was needed and not
found.

Linux platform affected, on MacOS works fine, check on other platforms in progress.
Comment 1 Michael Nazarov 2009-10-08 10:01:48 UTC
Here the message on x86 platform, it seems like possible network problem
but in such case fail should be detected during download:

Warning - could not install some modules: Selenium Module for Maven - The module named
org.netbeans.modules.selenium.server was needed and not found. Web Services Registry - The module named
org.netbeans.modules.websvc.jaxrpc16/1 was needed and not found. Code Coverage Plugin - The module named
com.vladium.emma/1 was needed and not found. Sun Java System Portal Server 7.x - The module named
org.netbeans.modules.portalpack.servers.base_psframework was needed and not found. JAX-RPC Support - The module named
org.netbeans.modules.websvc.jaxrpc16/1 was needed and not found. Another module could not be installed due to the above
problems.
Comment 2 Jiri Kovalsky 2009-10-08 10:05:05 UTC
Robert, is this something you can fix yourself? If not, please reassign to Martin Schovanek - Code Coverage plugin
owner. Thanks!
Comment 3 Michael Nazarov 2009-10-08 10:16:12 UTC
SPARC platform has it's own set of problematic modules.
So this is wider problem then just CCP issue...
Comment 4 Marian Mirilovic 2009-10-08 10:36:04 UTC
Ok, so for now I would vote for removing CC from UC, Robert could you do that ASAP ? Thanks in advance.
Comment 5 Michael Nazarov 2009-10-08 10:38:57 UTC
As I wrote unfortunately this might be not only CCP problem :(
I'm checking on Windows XP right now, let's see on most important platform.
Comment 6 rnovak 2009-10-08 10:57:57 UTC
I tested it in Linux, outside from swan and the download and installation was successful. I would say this is
updates.netbeans.org problem - downlaod is very slow especially in swan.
Comment 7 Michael Nazarov 2009-10-08 10:59:17 UTC
Why it was not detected during download?
Comment 8 rnovak 2009-10-08 11:35:42 UTC
I don't know. But the module is platform independent. Should behave in the same way on all the platforms.
Comment 9 Michael Nazarov 2009-10-08 11:38:26 UTC
That's true, and that's why I wrote this problem might be more complex then just corrupted CCP.
Comment 10 Michael Nazarov 2009-10-08 12:38:35 UTC
On Windows passed successfully.
Comment 11 dlipin 2009-10-08 13:26:33 UTC
btw, works fine on my windows box.
Comment 12 milutinjovanovic 2009-10-15 06:50:33 UTC
I hate to "confuse" the subject, but...

Using NetBeans 6.7:

I am getting the same error when trying to install Code Coverage plugin on Mac OS Snow Leopard, running Java 1.6 64bit.

On another machine, Windows XP, Java 1.6, it installs and runs properly.

To add some more information, as the problem might be settings related (you never know), the settings were from NetBeans
6.1, then upgraded to 6.5, then 6.7.
Comment 13 Jiri Kovalsky 2009-10-15 08:48:34 UTC
Dmitry, can you please look into the code and find out what "...was needed and not found." error means if it occurs
_after_ everything is correctly downloaded and should be just properly installed and turned on? Thanks!
Comment 14 Jiri Kovalsky 2009-10-15 10:29:19 UTC
*** Issue 156766 has been marked as a duplicate of this issue. ***
Comment 15 dlipin 2009-10-15 12:51:15 UTC
<userdir>/var/log/messages.log* files are very welcomed to investigate the issue.
Comment 16 dlipin 2009-10-15 14:15:52 UTC
I checked that on Linux today and it works perfectly (in swan).
Comment 17 dlipin 2009-10-16 11:18:54 UTC
btw, did you use "Run in background" checkbox to install updates in background?
Comment 18 Michael Nazarov 2009-10-22 10:36:51 UTC
Looks like plugin manger doesn't handle some error during plugin transfer,
so in case of network problems it silently ignores fail and continue
working. I don't know is this correct idea BTW.

Anyway I've got this error again with latest Beta on Linux but successfully
installed same things on MacOS.

And I did not use Background feature.
Comment 19 Michael Nazarov 2009-10-22 10:38:04 UTC
Created attachment 89914 [details]
logs
Comment 20 dlipin 2009-10-22 21:05:00 UTC
> Looks like plugin manger doesn't handle some error during plugin transfer, so in case of network problems it silently 
ignores fail and continue working. 

Do you have any arguments for that? 
I don`t see anything strange in log except the module activation issue:

WARNING [org.netbeans.core.startup.ModuleList]: Error encountered while reading com.vladium.emma

msg
Caused: org.netbeans.InvalidException: Not a module: no OpenIDE-Module tag in manifest of StandardModule:null jarFile: /
home/tester/netbeans-6.8beta/extra/modules/ext/emma.jar[invalid]
	at org.netbeans.Module.parseManifest(Module.java:311)
	at org.netbeans.StandardModule.<init>(StandardModule.java:133)
	at org.netbeans.ModuleFactory.create(ModuleFactory.java:65)
	at org.netbeans.ModuleManager.create(ModuleManager.java:503)
	at org.netbeans.core.startup.ModuleList$ReadInitial.run(ModuleList.java:1841)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:122)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:539)
	at org.netbeans.core.startup.ModuleList.readInitial(ModuleList.java:171)
	at org.netbeans.core.startup.ModuleSystem.readList(ModuleSystem.java:262)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:167)
	at org.netbeans.core.startup.Main.start(Main.java:309)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:111)
[catch] at java.lang.Thread.run(Thread.java:619)
ALL [null]: StandardModule:null jarFile: /home/tester/netbeans-6.8beta/extra/modules/ext/emma.jar[invalid] is not a 
valid NetBeans module.

That is very intersting why modules/ext/emma.jar is even tried to be treated as the standard NB module.

PS. NBMs are at
http://updates.netbeans.org/netbeans/updates/6.8/uc/beta/beta/modules/extra/com-vladium-emma.nbm
http://updates.netbeans.org/netbeans/updates/6.8/uc/beta/beta/modules/extra/org-netbeans-modules-coverage.nbm

PPS. Maybe it is due having classpath defined in com-vladium-emma.nbm!/netbeans/modules/com-vladium-emma.jar!/META-INF/
MANIFEST.MF
Class-Path: ext/emma.jar

BTW, I see the same "Class-Path" tag been used in jaxrpc16 which also seems to be problematic
org-netbeans-modules-websvc-jaxrpc16.nbm!/netbeans/modules/org-netbeans-modules-websvc-jaxrpc16.jar!/META-INF/
MANIFEST.MF 
http://updates.netbeans.org/netbeans/updates/6.8/uc/beta/stable/modules/extra/org-netbeans-modules-websvc-jaxrpc16.nbm

Jarda, any idea why those modules were not activated?
Is it related to 
http://www.netbeans.org/issues/show_bug.cgi?id=159093
http://www.netbeans.org/issues/show_bug.cgi?id=166333
?
Comment 21 Jaroslav Tulach 2009-10-27 13:14:28 UTC
I am not sure how can I help? I installed 
http://updates.netbeans.org/netbeans/updates/6.8/uc/beta/beta/modules/extra/com-vladium-emma.nbm
http://updates.netbeans.org/netbeans/updates/6.8/uc/beta/beta/modules/extra/org-netbeans-modules-coverage.nbm
successfully. Issue 166333 cannot be cause of this problem, as far as I can see.

I cannot comment on issue 159093. Reassigning to owner of platform/module system.
Comment 22 Petr Nejedly 2009-10-27 18:41:02 UTC
Well, you'd better find a real owner of platform/module system.
Anyway, the class path in com-vladium-emma.jar is OK and the ext/emma.jar should never be treated as a module too.
It works for me with 6.8beta on linux.
Comment 23 Petr Nejedly 2009-10-27 18:47:35 UTC
Note: After update, I have seen a CNFE in the console, but it was apparently an expected one (just logged loudly enough)
- org.netbeans.modules.j2ee.sun.ws7.WS7LibsClassLoader trying to load com.sun.web.admin.deployapi.SunDeploymentFactory
Comment 24 Jesse Glick 2009-10-29 16:35:23 UTC
Sounds like others have not managed to reproduce the issue, so this does not seem like a P1 to me.
Comment 25 Jesse Glick 2009-10-30 00:44:44 UTC
Trying with 6.8 beta:

1. After restart after first session, console got

Exception in thread "Thread-2" java.lang.AssertionError: Cannot delete /tmp/testud03/update/main/org/netbeans/javafx/install
	at org.netbeans.updater.ModuleUpdater.deleteDir(ModuleUpdater.java:702)
	at org.netbeans.updater.ModuleUpdater.deleteDir(ModuleUpdater.java:699)
	at org.netbeans.updater.ModuleUpdater.deleteDir(ModuleUpdater.java:699)
	at org.netbeans.updater.ModuleUpdater.deleteDir(ModuleUpdater.java:699)
	at org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:420)
	at org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:134)

2. Second session (after restart) said some modules could not be found:

Warning - could not install some modules:
	org.netbeans.modules.websvc.jaxrpckit - The module named org.netbeans.modules.websvc.jaxrpc was needed and not found.
	org.netbeans.modules.javafx.profiler - The module named org.netbeans.modules.javafx.editor was needed and not found.
	org.apache.jmeter.kit - The module named org.apache.jmeter.module/1 was needed and not found.
	org.apache.jmeter.kit - The module named org.netbeans.modules.profiler.loadgen/1 was needed and not found.
	org.netbeans.modules.javafx.kit - The module named org.netbeans.modules.javafx.editor was needed and not found.
	org.netbeans.modules.javafx.kit - The module named org.netbeans.modules.javafx.fxd was needed and not found.
	org.netbeans.modules.javafx.kit - The module org.netbeans.modules.javafx.navigation would also need to be installed.
	org.netbeans.modules.javafx.kit - The module org.netbeans.modules.javafx.profiler would also need to be installed.
	org.netbeans.modules.javafx.weather2 - The module org.netbeans.modules.javafx.kit would also need to be installed.
	org.netbeans.modules.javafx.navigation - The module named org.netbeans.modules.javafx.editor was needed and not found.

3. After I said to Exit, updater ran again - installing a bunch more things; IDE restarted, and seemed to load
everything fine.
Comment 26 dlipin 2009-10-30 11:16:47 UTC
"Cannot delete..." issue was fixed - see Issue 175196. Please verify in the latest daily build.

*** This issue has been marked as a duplicate of 175196 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo