Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 173990 - Copy pasted RunOffAWT code
Copy pasted RunOffAWT code
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@editor
: PERFORMANCE
Depends on: 170882
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 15:42 UTC by Jaroslav Tulach
Modified: 2009-11-12 04:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2009-10-07 15:42:39 UTC
The code in 
http://hg.netbeans.org/main-silver/rev/563345389351
seems to introduce a copy of a code in another part of NetBeans repository. Avoid copy/paste programming and rather 
invest your time into creation of proper API.
Comment 1 Jan Lahoda 2009-10-07 15:47:40 UTC
I this a joke?

*** This issue has been marked as a duplicate of 170882 ***
Comment 2 Jaroslav Tulach 2009-10-07 15:49:40 UTC
Is your duplication a joke? I will not trade closed bug for an enhancement. 
Comment 3 Jan Lahoda 2009-10-07 15:50:49 UTC
So why don't you make a defect from #170882?
Comment 4 Jaroslav Tulach 2009-10-07 16:40:16 UTC
This bug is reported to eliminate duplicated code, it may or may not depend on presence of new API in progress module.
Comment 5 Jan Lahoda 2009-10-07 16:43:11 UTC
Cannot practically be done without an API, and placing the API into the platform seems very appropriate to me. So, this
cannot be efficiently fixed without fixing issue #170882.
Comment 6 Jan Lahoda 2009-10-07 16:44:35 UTC
BTW: please define how much duplicated code (ideally by means of AST nodes, or byte code size) is considered a P3
defect. Otherwise this is an invalid bug.
Comment 7 Jaroslav Tulach 2009-10-07 17:38:51 UTC
IZ is not appropriate place for organizational discussion. But here is short and my last comment about this topic in 
this issue: As former Retouche member you should be aware of code duplication being bad thing. I believe we have to 
operate in mode where we need to ask for reasons why to duplicate code, and not why not. Clearly, in this case there 
is a simple way (issue 170882) to avoid duplication, as such I do not see a single reason why the duplication should 
be allowed. If you want to argue more about this, please raise your concerns to nbdev@ or other developer's mailing 
list. Thanks.
Comment 8 Jan Lahoda 2009-11-12 04:39:22 UTC
http://hg.netbeans.org/jet-main/rev/d651930d236d


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo