Bug 173913 - Illegal Window System API call off EQ
Illegal Window System API call off EQ
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
http://deadlock.netbeans.org/hudson/j...
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-06 21:19 UTC by Jesse Glick
Modified: 2009-10-09 23:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-10-06 21:19:46 UTC
WARNING [org.netbeans.core.windows.WindowManagerImpl]
java.lang.IllegalStateException: Problem in some module which uses Window System: Window System API is required to be
called from AWT thread only, see http://core.netbeans.org/proposals/threading/
	at org.netbeans.core.windows.WindowManagerImpl.warnIfNotInEDT(WindowManagerImpl.java:1517)
	at org.netbeans.core.windows.WindowManagerImpl.findTopComponent(WindowManagerImpl.java:250)
	at org.netbeans.modules.debugger.jpda.JavaEngineProvider$1ComponentProxy.getComponent(JavaEngineProvider.java:101)
[catch] at org.netbeans.modules.debugger.ui.DebuggerManagerListener$1.run(DebuggerManagerListener.java:127)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1084)
Comment 1 Martin Entlicher 2009-10-07 13:35:49 UTC
Caused by the fix of issue #173712.
Comment 2 Martin Entlicher 2009-10-07 13:36:53 UTC
BTW: I consider the behavior of WindowManagerImpl.warnIfNotInEDT() very unfortunate, I've tested the behavior before
integration and did not get anything in messages.log file!
Comment 3 Martin Entlicher 2009-10-07 14:39:33 UTC
Fixed in changeset:   148424:5c5689e79c97
http://hg.netbeans.org/main/rev/5c5689e79c97
Comment 4 Jesse Glick 2009-10-07 17:06:09 UTC
Perhaps your manual testing did not exercise the same code path as commit validation does. Hard to say.
Comment 5 Quality Engineering 2009-10-09 23:00:17 UTC
Integrated into 'main-golden', will be available in build *200910091401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5c5689e79c97
User: mentlicher@netbeans.org
Log: #173913 - Components must be loaded in AWT.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo