Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 173800 - [68cat] Heap Size property unavailable for jnlp RCP projects
[68cat] Heap Size property unavailable for jnlp RCP projects
Status: RESOLVED DUPLICATE of bug 181264
Product: apisupport
Classification: Unclassified
Component: Harness
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-05 22:08 UTC by javydreamercsw
Modified: 2010-07-26 13:51 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2009-10-05 22:08:05 UTC
Build 200910010513

The current RCP project structure doesn't provide for specifying heap size properties for the java resources (i.e. 
java="1.5+ "initial-heap-size="64m" max-heap-size ="512m") This can't be done in the master.jnlp as this is part of 
the ${jnlp.resources} replacement. I think target java version plus options like heap size should be configurable and 
not assumed. You can't even require 1.6 that is the minimum for current RCP if I'm correct.

This might be considered as a feature request but I think is important enough.
Comment 1 Milan Kubec 2009-10-06 09:35:57 UTC
Reassigning to apisupport that is responsible for javawebstart of RCP application and changing to enhancement.
Comment 2 javydreamercsw 2010-07-26 13:51:24 UTC
Keeping the one from the Netbeans Team for project tracking purposes.

*** This bug has been marked as a duplicate of bug 181264 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo