Bug 173736 - Session bean created with errors in JavaEE6 web app
Session bean created with errors in JavaEE6 web app
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Maven
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
:
Depends on:
Blocks: 173743
  Show dependency treegraph
 
Reported: 2009-10-05 10:52 UTC by Jaroslav Pospisil
Modified: 2009-10-12 15:24 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2009-10-05 10:52:09 UTC
latest Beta , Win Vista, JDK1.6.0_16

Create new JavaEE6 Maven Web Application and add Session bean.
Bean is created with errors,since it doesn't know javax.ejb package and when I invoke Insert Code action,as suggested in
javadoc, there's missing Add Bussiness Method action.
Comment 1 Jaroslav Pospisil 2009-10-05 12:47:00 UTC
The same problem occurs,when create Servlet in JavaEE6 maven web application. 
Problem seems to be caused by error on repository side. Both libraries reported missing by IDE, were updated 2/10/2009
and seems to be,that update went wrong,since they have bad size. 
Comment 2 Milos Kleint 2009-10-05 13:02:31 UTC
The problem is in the data currently present in the java.net M2 repository.
http://download.java.net/maven/2/javax/javaee-web-api/
the jar shrinked from 900k to 180k on Oct 2, missing many j2ee API. that same applies to the javaee-api jar (for the
full profile)

There is nothing we can do in netbeans alone, I will alert the glassfish people ASAP and will keep the issue opened
until it's resolved.
Comment 3 Milos Kleint 2009-10-05 13:44:17 UTC
-> P1
Comment 4 Antonin Nebuzelsky 2009-10-05 20:02:43 UTC
Fixed on GF side now.
Comment 5 Jaroslav Pospisil 2009-10-12 15:24:04 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo