Bug 173442 - Run on EJB Jar project fails to Deploy
Run on EJB Jar project fails to Deploy
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: EJB Project
6.x
Sun All
: P1 (vote)
: 6.x
Assigned To: Petr Hejl
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-01 01:23 UTC by Vince Kraemer
Modified: 2009-10-07 00:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
a patch that seems to work (1.37 KB, text/plain)
2009-10-01 01:36 UTC, Vince Kraemer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2009-10-01 01:23:50 UTC
using a recently pulled release6_beta clone

register gf v3
create an ejb jar project that targets that server.
add a session bean to the project
Use the Deploy item on the project's right click menu...

See this in the ant output window...

Initializing...
/export/home/vkraemer/cvs.java.net/glassfish-samples/ws/javaee6/webservices/hello-singleton-ejb/nbproject/build-impl.xml:450:

Deployment error:
null
See the server log for details.
        at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:227)
        at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:135)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:103)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor35.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:357)
        at org.apache.tools.ant.Target.performTasks(Target.java:385)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
        at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:278)
        at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:498)
        at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
Caused by: java.lang.NullPointerException
        at
org.netbeans.modules.j2ee.deployment.impl.projects.DeploymentTargetImpl.getClientUrl(DeploymentTargetImpl.java:126)
        at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:207)
        ... 17 more
BUILD FAILED (total time: 0 seconds)

One other note.... The deployment actually was successful, this failure is in some of the post processing that takes
place to support opening the browser to a specific page... which is kind of irrelevant for an ejb-jar project anyway.
Comment 1 Vince Kraemer 2009-10-01 01:36:19 UTC
Created attachment 88635 [details]
a patch that seems to work
Comment 2 Vince Kraemer 2009-10-01 01:46:29 UTC
it would be nice to get this fix in for the beta.

some of the Java EE 6 samples need to deploy a stand-alone ejb-jar file.
Comment 3 Petr Hejl 2009-10-01 10:39:00 UTC
Patch seems to be ok. Fixed in in web-main bf5ccf3d945d.
Thanks Vince!
Comment 4 Martin Schovanek 2009-10-01 10:48:24 UTC
BETA STOPPER => P1

Please integrate into release68_clone ASAP.
Comment 5 Petr Hejl 2009-10-01 13:54:21 UTC
There was another NPE hidden in the patch - fixed in web-main d3ed927be9e7.
Comment 6 Petr Hejl 2009-10-01 14:57:09 UTC
Transplanted to release68_beta - 239414c96c84 and 64e604e9d07f.
Comment 7 Quality Engineering 2009-10-05 08:49:35 UTC
Integrated into 'main-golden', will be available in build *200910030241* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bf5ccf3d945d
User: phejl@netbeans.org
Log: #173442 Run on EJB Jar project fails to Deploy
Comment 8 Martin Schovanek 2009-10-05 10:38:25 UTC
Verified in  NetBeans IDE 6.8 Beta (Build 200910020947).
Comment 9 Quality Engineering 2009-10-07 00:07:00 UTC
Integrated into 'main-golden', will be available in build *200910061401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bf5ccf3d945d
User: phejl@netbeans.org
Log: #173442 Run on EJB Jar project fails to Deploy


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo