Bug 173382 - StackOverFlow when invoking CC
StackOverFlow when invoking CC
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Editing
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
:
: 173450 173992 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 12:13 UTC by Erno Mononen
Modified: 2009-10-07 15:58 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.09 KB, text/plain)
2009-09-30 12:14 UTC, Erno Mononen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erno Mononen 2009-09-30 12:13:27 UTC
Encountered the following exception when invoking CC in a controller of a rails app. Appears to happen only in this 
project and is not 100% reproducible. Likely caused by trying to read index during indexing.

java.lang.StackOverflowError
        at org.openide.util.RequestProcessor$Task.waitFinished(RequestProcessor.java:755)
        at org.openide.loaders.FolderList.waitProcessingFinished(FolderList.java:296)
        at org.openide.loaders.FolderInstance.waitProcessingFinished(FolderInstance.java:646)
...
Comment 1 Erno Mononen 2009-09-30 12:14:43 UTC
Created attachment 88591 [details]
stacktrace
Comment 2 Erno Mononen 2009-09-30 13:39:04 UTC
Seems to happen often enough to make this at least a P2.
Comment 3 Erno Mononen 2009-09-30 14:33:41 UTC
Fixed in 71f6511124b6. This was a recent regression caused by b789f4bb549f. The issue is reproducible e.g. in a rails 
controller that contains for example an assignment like the following:

@user = User.active.find(params[:id])
Comment 4 Tomas Danek 2009-09-30 15:02:27 UTC
reproduced in beta. Will verify the fix ruby-main and later in beta.
Comment 5 Marian Mirilovic 2009-09-30 15:24:26 UTC
Ok, go ahead and integrate to beta after verification in trunk. Thanks in advance.
Comment 6 Tomas Danek 2009-09-30 15:59:40 UTC
unable to reproduce, verified in NetBeans IDE Dev (Build 090930) (#261c97da93d2)
Comment 7 Erno Mononen 2009-09-30 16:24:10 UTC
Fixed in release68_beta, 6630f47adf6f.
Comment 8 Tomas Danek 2009-10-01 10:30:34 UTC
Verified in beta

Product Version: NetBeans IDE 6.8 Beta (Build 200909302201)
Java: 1.5.0_20; Java HotSpot(TM) Client VM 1.5.0_20-141
System: Mac OS X version 10.5.8 running on i386; MacRoman; en_US (nb)
Userdir: /Users/tomas/.netbeans/6.8beta
Comment 9 Quality Engineering 2009-10-01 17:23:05 UTC
Integrated into 'main-golden', will be available in build *200910010513* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/71f6511124b6
User: Erno Mononen <emononen@netbeans.org>
Log: #173382: StackOverFlow when invoking CC
- Backed out changeset b789f4bb549f
Comment 10 Erno Mononen 2009-10-02 14:52:49 UTC
*** Issue 173450 has been marked as a duplicate of this issue. ***
Comment 11 Erno Mononen 2009-10-07 15:58:16 UTC
*** Issue 173992 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo