Bug 173231 - [68cat] java.util.ConcurrentModificationException at java.util.LinkedHashMap$LinkedHashIterator.nextEntry
[68cat] java.util.ConcurrentModificationException at java.util.LinkedHashMap$...
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 173247 173253 173255 173284 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-29 08:57 UTC by Peter Nabbefeld
Modified: 2009-10-14 18:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.76 KB, text/plain)
2009-09-29 08:57 UTC, Peter Nabbefeld
Details
stacktrace (3.24 KB, text/plain)
2009-09-30 10:08 UTC, mklaehn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Nabbefeld 2009-09-29 08:57:20 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3998-on-090927)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments:
epdv: Closed an open Java application project



Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.LinkedHashMap$LinkedHashIterator.nextEntry(LinkedHashMap.java:373)
        at java.util.LinkedHashMap$KeyIterator.next(LinkedHashMap.java:384)
        at org.netbeans.modules.versioning.VersioningManager.getLocalHistory(VersioningManager.java:304)
        at org.netbeans.modules.versioning.FilesystemInterceptor.getInterceptor(FilesystemInterceptor.java:285)
        at org.netbeans.modules.versioning.FilesystemInterceptor.getAttribute(FilesystemInterceptor.java:117)
        at org.netbeans.modules.masterfs.ProvidedExtensionsProxy$11.run(ProvidedExtensionsProxy.java:261)
Comment 1 Peter Nabbefeld 2009-09-29 08:57:24 UTC
Created attachment 88474 [details]
stacktrace
Comment 2 Tomas Stupka 2009-09-29 09:09:59 UTC
fixed

changeset   : 147240:7fbe491965ec
author      : Tomas Stupka <tstupka@netbeans.org>
date        : Tue Sep 29 10:09:36 CEST 2009
Comment 3 Tomas Stupka 2009-09-29 10:58:06 UTC
*** Issue 173247 has been marked as a duplicate of this issue. ***
Comment 4 Tomas Stupka 2009-09-29 14:35:02 UTC
*** Issue 173253 has been marked as a duplicate of this issue. ***
Comment 5 Tomas Stupka 2009-09-29 14:35:31 UTC
potential data loss, already 2 duplicates -> p1
Comment 6 Jaromir Uhrik 2009-09-29 14:47:20 UTC
This is stopper for 6.8Beta. After we will verify it in trunk it needs to be ported to 6.8Beta branch.
Comment 7 Tomas Stupka 2009-09-29 15:30:12 UTC
*** Issue 173284 has been marked as a duplicate of this issue. ***
Comment 8 mklaehn 2009-09-30 10:08:22 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3998-on-090927)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows Vista, 6.0, amd64

User Comments: 


Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.LinkedHashMap$LinkedHashIterator.nextEntry(LinkedHashMap.java:373)
        at java.util.LinkedHashMap$KeyIterator.next(LinkedHashMap.java:384)
        at org.netbeans.modules.versioning.VersioningManager.getLocalHistory(VersioningManager.java:304)
        at org.netbeans.modules.versioning.FilesystemInterceptor.getInterceptor(FilesystemInterceptor.java:253)
        at org.netbeans.modules.versioning.FilesystemInterceptor.fileDataCreated(FilesystemInterceptor.java:208)
        at org.netbeans.modules.versioning.FilesystemInterceptor.fileFolderCreated(FilesystemInterceptor.java:192)
Comment 9 mklaehn 2009-09-30 10:08:26 UTC
Created attachment 88576 [details]
stacktrace
Comment 10 Tomas Stupka 2009-09-30 10:43:30 UTC
*** Issue 173255 has been marked as a duplicate of this issue. ***
Comment 11 Jaromir Uhrik 2009-09-30 16:32:01 UTC
Verified in the private cdev build. The fix is ready to be integrated to 6.8 Beta. Tomasi, please push the fix to 68
beta clone. Thanks.
Comment 12 Quality Engineering 2009-10-01 00:48:28 UTC
Integrated into 'main-golden', will be available in build *200909301401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7fbe491965ec
User: Tomas Stupka <tstupka@netbeans.org>
Log: #173231 - [68cat] java.util.ConcurrentModificationException at java.util.LinkedHashMap$LinkedHashIterator.nextEntry
Comment 13 Tomas Stupka 2009-10-01 08:04:25 UTC
pushed into release68_beta

changeset   : 147241:6b5862b47522
author      : Tomas Stupka <tstupka@netbeans.org>
date        : Wed Sep 30 17:30:12 CEST 2009


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo