Bug 173138 - Web app was hard coded to run on a particular port
Web app was hard coded to run on a particular port
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
PC Windows XP x64
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-25 22:27 UTC by davisn
Modified: 2009-10-01 00:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (454.80 KB, text/plain)
2009-09-25 22:29 UTC, davisn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davisn 2009-09-25 22:27:12 UTC
If I create a web application to run with the default V3 domain1 server (port 8080), I was not able to run the
application with other V3 domain which has server port different than 8080

Steps To Reproduce
1. Install NB Trunk build 09/22/2009
2. Start NB IDE -> select to add a new V3 server by select to download it -> change to domain2 at "Register Local
Domain" field
Note:
  IDE will create domain2 with a random server port
3. Create a web application with having GlassFish V3 Domain as runtime server
4. Select to run the application
5. Stop GlassFish V3 Domain server
6. Select to change the application to have runtime server as download domain2
7. Run the Application 
BUG:
    The app was deployed successfully; however, the browser tried to access to the GlassFish V3 Domain port 8080 instead
of the download domain2 port
Comment 1 davisn 2009-09-25 22:29:18 UTC
Created attachment 88389 [details]
messages.log
Comment 2 davisn 2009-09-25 23:09:05 UTC
If I switch to Services -> Servers -> download-domain2 -> Applications -> testApp and select to "Open in Browser" the
app then the application was open correctly in the browser.
Comment 3 Vince Kraemer 2009-09-26 10:40:22 UTC
that was a great catch.

it looks like this bug has been in the product since March, 2009.
Comment 4 Vince Kraemer 2009-09-26 10:40:51 UTC
i have started to fix this
Comment 5 Vince Kraemer 2009-09-27 17:17:19 UTC
http://hg.netbeans.org/web-main/rev/00f29bb34fc9
Comment 6 Quality Engineering 2009-10-01 00:47:53 UTC
Integrated into 'main-golden', will be available in build *200909301401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/00f29bb34fc9
User: vince kraemer <vkraemer@netbeans.org>
Log: #173138: bad key for Hk2TargetModuleID when target changes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo