Bug 172592 - [69cat] AWT thread blocked for 21063 ms.
[69cat] AWT thread blocked for 21063 ms.
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: Manager
6.x
All All
: P3 (vote)
: 7.0.1
Assigned To: Denis Anisimov
issues@webservices
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE, REGRESSION
: 173070 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-19 02:06 UTC by Exceptions Reporter
Modified: 2011-04-29 04:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (60.90 KB, bin/nps)
2009-09-19 02:06 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2009-09-19 02:06:43 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments:
misterm: Opening project node for freeform project


Maximum slowness yet reported was 21063 ms, average is 8565
Comment 1 Exceptions Reporter 2009-09-19 02:06:48 UTC
Created attachment 87944 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-09-19 02:06:53 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157446
Comment 3 t_h 2009-09-21 09:51:33 UTC
SaasNodeChildren should initialize immediately or be asynchronous. In the snapshot initialization takes > 20s.
Comment 4 Exceptions Reporter 2009-10-01 15:27:05 UTC
This issue already has 8 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157446
Comment 5 Milan Kuchtiak 2009-10-01 15:49:32 UTC
The snapshots lead to websvc.manager code.
Comment 6 Milan Kuchtiak 2009-10-01 15:51:04 UTC
*** Issue 173070 has been marked as a duplicate of this issue. ***
Comment 7 Exceptions Reporter 2009-10-08 17:40:47 UTC
This issue already has 14 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157446
Comment 8 Michel Graciano 2009-10-08 17:47:16 UTC
As my latest (275393 and some others) posts, I just can't change the selected file in Projects view. I consider it an 
regression and just can be found at latest build 200910071536. The build 200910070250 doesn't has this regression.
Comment 9 Michel Graciano 2009-10-08 18:53:01 UTC
I decreased the priority since I just removed my indexes and it looks it like is working again.
Comment 10 Michel Graciano 2009-10-10 03:06:09 UTC
BTW, I added new comments at report and looks like the component and subcomponent are incorrect here.
Comment 11 Denis Anisimov 2010-11-01 11:01:58 UTC
The problem is inside websvc.saas.api module.
The stacktrace of the problem starts from SaasNodeChildren class ( websvc.saas.ui)
and its method addNotify() which calls toStateReady( false ) of Saas class .
The last one is overridden by WsdlSaas method.
The parameter value "false" means that call should be performed asynchronously 
which should prevent UI freeze. 
But there is no special logic which handles asynchronous essence .
The problem of the attached nps file is call WsdlUtil.getWsdlData() which asks 
WSDL model . It has parameter for asynchronous call but implementation ignores
this parameter. 
But WsdlSaas.toStateReady() implementation logic is still badly written 
because even WsdlUtil.getWsdlData() implementation is correctly written 
respectively asynchronous call its return value cannot be used for further 
work in the caller thread. All further work should be done after notification 
of finished task.

So actually either
- there is no need in asynchronous call of WsdlUtil.getWsdlData()
and toStateReady() method should put all its code into dedicated thread in case
of asynchronous request
or
- WsdlUtil.getWsdlData() should be implemented correctly according asynchronous 
parameter value and logic of toStateReady() should be rewritten respectively.

It's too risky to fix this bug for the upcoming release. Should be fixed in the
next release.
Comment 12 Denis Anisimov 2011-04-27 11:08:06 UTC
changeset:   192950:fb3f88ee9b22
Comment 13 Quality Engineering 2011-04-29 04:43:23 UTC
Integrated into 'main-golden', will be available in build *201104290000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/fb3f88ee9b22
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#172592 - [69cat] AWT thread blocked for 21063 ms.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo