Bug 172512 - Editor should allow multiple rows of tabs
Editor should allow multiple rows of tabs
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
7.1
All All
: P1 with 36 votes (vote)
: 7.2
Assigned To: Stanislav Aubrecht
issues@platform
:
: 183235 (view as bug list)
Depends on: 169099
Blocks: 207734
  Show dependency treegraph
 
Reported: 2009-09-17 18:35 UTC by twolf2919
Modified: 2013-02-19 21:38 UTC (History)
7 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
bug screenshot (49.60 KB, image/jpeg)
2012-01-26 21:38 UTC, e.pavlenko
Details
single row screen shot (66.77 KB, image/png)
2012-02-14 20:48 UTC, twolf2919
Details
multi-row screen shot (61.12 KB, image/png)
2012-02-14 20:48 UTC, twolf2919
Details

Note You need to log in before you can comment on or make changes to this bug.
Description twolf2919 2009-09-17 18:35:22 UTC
This has been irking me since 4.0 days when Netbeans developers decided, over the objections of many users, to eliminate
the ability to see multiple rows of tabs in the editor.  Now, only a single row is visible with a combo-box from which
to pick the rest.  For many of us, clicking on a combo-box and then clicking a file (after looking through a possibly
lengthy alphabetic list) is not as efficient than simply clicking on the tab!  It's ok if the default behavior is this -
if the NB developers are convinced this is the better way.  But it's not ok to completely ignore others who think
otherwise!  Just give us an option!  How hard could it be - it was there before in 3.x and JTabbedPane (now at least)
supports multi-row tabs natively.

I'm filing this issue after living with this for a couple years because a poster to nbusers had the same comment and
referred me to a thread in 2008 regarding this topic:
     http://forums.netbeans.org/viewtopic.php?t=8344&highlight=

Please bring this feature back.
Comment 1 the.flamming.moe 2010-05-31 15:33:14 UTC
(In reply to comment #0)
> This has been irking me since 4.0 days when Netbeans developers decided, over
> the objections of many users, to eliminate
> the ability to see multiple rows of tabs in the editor.  Now, only a single row
> is visible with a combo-box from which
> to pick the rest.  For many of us, clicking on a combo-box and then clicking a
> file (after looking through a possibly
> lengthy alphabetic list) is not as efficient than simply clicking on the tab! 
> It's ok if the default behavior is this -
> if the NB developers are convinced this is the better way.  But it's not ok to
> completely ignore others who think
> otherwise!  Just give us an option!  How hard could it be - it was there before
> in 3.x and JTabbedPane (now at least)
> supports multi-row tabs natively.
> 
> I'm filing this issue after living with this for a couple years because a
> poster to nbusers had the same comment and
> referred me to a thread in 2008 regarding this topic:
>      http://forums.netbeans.org/viewtopic.php?t=8344&highlight=
> 
> Please bring this feature back.


+1
Comment 2 twolf2919 2010-06-14 13:32:30 UTC
There are 14 votes but no action on what should be a pretty easy enhancement (Netbeans used to have multi-row tabs and JTabbedPane, if NB uses it for the editor tabs has that capability built-in).

I want to offer another use-case for re-introducing multi-row-tabs: what do you do when you have too many files open?  As I work on my project (edit, refactor, look-up definitions, etc.) editor tabs proliferate.  After only a short while, I may have 20-30 tabs open.  In order for me to be able to find previously opened files more effectively, I sometimes want to "prune" the files I'm no longer interested in.  When we had the multi-row tab display in NB, it was easy: just peruse the tabs and click on the 'close' button on the tabs I no longer care about.  Since opened tabs tend to be for the same activity, pruning typically involves closing tabs that are adjacent to one another - very easy.

In the single-row world, it's much more difficult: I have to reach over to the right and click on the drop-down that shows all open tabs; I have to search through a linear, alphabetized (vs. time-based) list of files, click on the one I want to close, and then click on the 'close' button on the activated tab.  I then have to repeat the process all over again for the next file to be closed.  This is painfully slow.

The only thing that single-row tabs have going for them is that they save on vertical real estate - not a very strong advantage in a world of high-resolution monitors.
Comment 3 ulfzibis 2011-02-23 12:02:35 UTC
*** Bug 100374 has been marked as a duplicate of this bug. ***
Comment 4 ulfzibis 2011-02-23 12:03:42 UTC
Seems to be a defect, as we had it available before.
Comment 5 ulfzibis 2011-02-23 12:05:31 UTC
REGRESSION justification see: Bug 100374
Comment 6 ulfzibis 2011-02-23 12:09:01 UTC
I mixed 2 bug IDs. sorry !
Comment 7 bojloc 2011-04-20 14:51:59 UTC
Any progress with this bug/feature? Will it be implemented?
Comment 8 e.pavlenko 2011-08-17 09:21:24 UTC
Working with NetBeans for several months and only one line of of tabs is the worst lack of functionality. It really slows down the work. Please fix it, give people to choose which way they want to work with documents.
Comment 9 markko1 2011-09-22 12:59:19 UTC
+1 vote from me. for some reason can't vote :-(
Comment 10 eflat 2011-11-29 20:54:54 UTC
I don't think about my ide much, which is good....except when I've got "too many" tabs open and I need to start scrolling the tabs or using the drop down. Quite unnatural to the workflow and gets in the way. Please add this improvement.
Comment 11 ulfzibis 2011-11-29 21:03:33 UTC
See also: bug 80890
Comment 12 ulfzibis 2011-11-29 21:09:26 UTC
See also: bug 142672
Comment 13 Dedo 2011-11-30 08:48:07 UTC
+1 for me. Even Notepad++ has this type of feature and it saved me a lot of time. Netbeans should too.
Comment 14 ulfzibis 2011-12-01 13:41:11 UTC
(In reply to comment #13)
> +1 for me.
Where is your vote?

> Even Notepad++ has this type of feature and it saved me a lot of time.
> Netbeans should too.
Yes, there are many valuable features in Notepad++, where NetBeans IDE could learn from, especially the smart, but powerful Find/Replace dialogue IMHO.
See: 146818
Comment 15 e.pavlenko 2011-12-01 16:24:34 UTC
> Yes, there are many valuable features in Notepad++, where NetBeans IDE could
> learn from, especially the smart, but powerful Find/Replace dialogue IMHO.

This is not just a valuable feature - for me (and I think for many developers) it is "must have", because in current implementation of Tabs in NetBeans it is not possible to work quickly if you have many documents opened, you spend too much time to switch between them.

The best example of how to do it in most convenient way is EditPlus:
- Lines of tabs always have the same position (they don't jump up or down) - so you always know where is the document you need
- All tabs are the same width - so you always know what will be under your mouse cursor when you close one tab.

In NetBeans you need to spend sometimes some 10 seconds, just to find a document and switch to it. And when you need to switch between two documents very often you must move tabs. Moving tabs in netbeans is not very quick and if you need to move a tab to the position which is not visible at the moment you can spend some 30 seconds. While moving the tab you can drop it somewhere else by mistake.
If you want to switch quickly, you aways need to close documents and to open them again.
You just spend a lot of time to move, close and open these tabs instead of coding.
Comment 16 jorj 2011-12-10 21:00:26 UTC
This feature is important enough to make me create this account at netbeans.org
I'm working with Symfony framework and I find myself with 5 files out of 25 opened having the same name. Any kind of help speeding the switching between files would be of a GREAT help.
Comment 17 jorj 2011-12-11 14:02:34 UTC
I got back with a solution until this bug will be solved somehow. I'm using the favorites window (Ctrl-3) and I bookmark my important files from Tools->Add to favorites. The items in the favorites list can be renamed and reordered without affecting the files while and the list is vertical, as a menu. For now is a good substitute.
Comment 18 nullone 2012-01-06 19:38:00 UTC
IDE is a tool to make developer's work and life easier, I suppose people agree with me.

In a non-toy project, it is very easy to open and work on many files, and developers need to switch among them time by time and do not want to get disturbed.

It is nature to have a one-click multi-line tab to meet the need.


Somebody prefer one-line tab, and claims the search or drop-down box works fine to look and locate the file developers want to work on.

How about only allow those guys to work on a 12" monitor (800x600), or Google/Yahoo Maps never zoom for them, since "you can click and move to where you want".

Wake up guys. This is really painful.
The pain remind me of the good old Delphi days, which was more than 10 years ago.

I also think the evolution shall go forward.
Comment 19 Stanislav Aubrecht 2012-01-25 10:14:24 UTC
core-main e36924dd340d
Comment 20 Quality Engineering 2012-01-26 16:10:45 UTC
Integrated into 'main-golden', will be available in build *201201260600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e36924dd340d
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #172512 - Support multiple rows of tabs for editor windows
Comment 21 twolf2919 2012-01-26 16:37:23 UTC
Stan,
Just wanted to thank you for implementing this feature - thanks a bunch!
Comment 22 e.pavlenko 2012-01-26 21:35:43 UTC
Thank you very much!

But is it possible to make these tabs not to jump when I switch between lines of tabs? If you remember where is a file you need, you can switch to it much faster. But if lines of tabs are jumping, you always need to search a tab you need, befeore you can switch to it. If this jumping is made to preserve the design of TABS you better change tabs to buttons it will be much more convenient.
Also all tabs must be the same width, so you always know what will be under your mose cursor when you close one tab. And you always know where are your alreay opened important tabs are when you open a new tab.

I found a bug:
- You have two lines of tabs. In one first there are 3 documents. In second line there are 6 documents.
- If you click on the free space of the tab in first line you cannot switch to it. Netbeans takes this click as if you clieck on the second line on the same X-axis position.
Comment 23 e.pavlenko 2012-01-26 21:38:35 UTC
Created attachment 115288 [details]
bug screenshot

If I clieck on 1 (index.php) the tab 2 (ref.php) will be selected.
You can switch to index.php only if you click on the text "index.php".
Comment 24 Stanislav Aubrecht 2012-01-27 11:06:14 UTC
please open a new issue if you want to report bugs in multirow tabs
Comment 25 nullone 2012-01-31 20:10:29 UTC
Happened to see this great news in NB news weekly letter.

The link, however, points to 
http://blogs.oracle.com/geertjan/entry/upcoming_netbeans_feature_multi_row

And the Oracle news web site hired some spam filtering service, and that service was smart enough to think my post is spam, so I could not comment on somebody's resistance to this great feature.

I will post my response here.

"Havoc Pennington's essay on Free Software UIs (2002), especially the section about why adding more preferences has a cost"

---of course at the cost of development, but your user will gain more freedom and your software is more flexible and adapter-able, which means it can survive longer or create greater value in a changing world.

The problem today for most people is blindly trusting and following what ever printed on paper. Go live your own life, trust your own eyes and feeling, and let others do that too.
Comment 26 Geertjan Wielenga 2012-01-31 22:21:36 UTC
The spam filtering service means that your comment ended up in my moderation queue. And I approved it and so now it is visible in my blog. Stop leaving comments here, the issue is closed.
Comment 27 twolf2919 2012-02-14 20:47:06 UTC
I'm re-opening as multi-row tabs don't work - at least not as of the 02/14 dev build on a Mac.  See attached screen shots: the first one shows the traditional single row of tabs.  The second one shows the display when Preferences->Miscellaneous->Windows->Multi-row tabs is checked.

When Mult-row is checked, the tabs simply become bigger with a big/ugly "left" arrow on the left to indicate that there are hidden tabs.
Comment 28 twolf2919 2012-02-14 20:48:13 UTC
Created attachment 115724 [details]
single row screen shot
Comment 29 twolf2919 2012-02-14 20:48:49 UTC
Created attachment 115725 [details]
multi-row screen shot
Comment 30 Stanislav Aubrecht 2012-02-15 09:31:11 UTC
multi-row tabs are based on Swing JTabbedPane and for some reason the aqua l&f on mac implements WRAP_TAB_LAYOUT this way.
feel free to file a bug against aqua l&f or write your own tab implementation (there's a new api for that)
Comment 31 Stanislav Aubrecht 2012-04-16 13:38:07 UTC
(In reply to comment #30)
> multi-row tabs are based on Swing JTabbedPane and for some reason the aqua l&f
> on mac implements WRAP_TAB_LAYOUT this way.
> feel free to file a bug against aqua l&f or write your own tab implementation
> (there's a new api for that)

Closing
Comment 32 markiewb 2013-02-19 21:38:08 UTC
*** Bug 183235 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo