Bug 172186 - Editor bookmarks (was: AWT thread blocked for 3065 ms.)
Editor bookmarks (was: AWT thread blocked for 3065 ms.)
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
All All
: P3 (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 185121 186436 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 15:00 UTC by Exceptions Reporter
Modified: 2012-11-15 09:02 UTC (History)
109 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (15.99 KB, bin/nps)
2009-09-14 15:00 UTC, Exceptions Reporter
Details
nps snapshot (14.77 KB, bin/nps)
2009-09-24 10:07 UTC, stefan79
Details
nps snapshot (256.00 KB, application/nps)
2009-11-12 13:09 UTC, jfderaismes
Details
nps snapshot (256.00 KB, application/nps)
2009-12-17 07:14 UTC, jfderaismes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2009-09-14 15:00:49 UTC
Build: NetBeans IDE Dev (Build 200909132344)
VM: Java HotSpot(TM) Client VM, 16.0-b06, Java(TM) SE Runtime Environment, 1.7.0-ea-b66
OS: Windows XP, 5.1, x86

User Comments:
xiaozhen0: just finished my lunch

GUEST: opening recent projects


Maximum slowness yet reported was 10844 ms, average is 4946
Comment 1 Exceptions Reporter 2009-09-14 15:00:53 UTC
Created attachment 87614 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-09-14 15:01:04 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 3 Milan Kubec 2009-09-15 14:39:37 UTC
Loading bookmarks should not be done in AWT EQ.
Comment 4 stefan79 2009-09-24 10:06:45 UTC
Build: NetBeans IDE Dev (Build 200909221401)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows XP, 5.1, x86

User Comments: 
Opened a file while Scanning projects.
Maximum slowness yet reported was 10844 ms, average is 4724
Comment 5 stefan79 2009-09-24 10:07:09 UTC
Created attachment 88259 [details]
nps snapshot
Comment 6 Exceptions Reporter 2009-09-24 10:07:23 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 7 Exceptions Reporter 2009-10-08 15:49:48 UTC
This issue already has 12 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 8 Exceptions Reporter 2009-10-08 18:53:43 UTC
This issue already has 13 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 9 Exceptions Reporter 2009-10-09 09:19:57 UTC
This issue already has 14 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 10 Exceptions Reporter 2009-11-11 01:59:13 UTC
This issue already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 11 Vitezslav Stejskal 2009-11-11 02:47:02 UTC
It's not that dramatic.
Comment 12 Exceptions Reporter 2009-11-11 05:13:41 UTC
This issue already has 51 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 13 Exceptions Reporter 2009-11-11 09:17:57 UTC
This issue already has 52 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 14 Exceptions Reporter 2009-11-11 16:26:03 UTC
This issue already has 53 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 15 David Strupl 2009-11-12 01:55:05 UTC
This is not a P1. I have filed #176513 to stop the exception reporter making it P1.
Comment 16 jfderaismes 2009-11-12 13:09:24 UTC
Created attachment 90943 [details]
nps snapshot
Comment 17 Exceptions Reporter 2009-11-25 07:40:23 UTC
This bug already has 100 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=157407
Comment 18 Jindrich Sedek 2009-11-25 07:51:05 UTC
oups... priority should not be changed for slowness reports...
Comment 19 jfderaismes 2009-12-17 07:14:50 UTC
Created attachment 92711 [details]
nps snapshot
Comment 20 Vitezslav Stejskal 2010-05-21 07:28:06 UTC
*** Bug 186436 has been marked as a duplicate of this bug. ***
Comment 21 Vitezslav Stejskal 2010-06-14 15:00:21 UTC
*** Bug 185121 has been marked as a duplicate of this bug. ***
Comment 22 David Strupl 2012-11-15 09:02:04 UTC
The recent reports from bookmarks were fixed by Mila when fixing #211851

http://hg.netbeans.org/jet-main/rev/c9cf1bcaa3bc

The bookmarks loading is now done in a background thread. Closing this report as fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo