Bug 172006 - Portlet container driver does not work when appserver is installed into folder with space in path
Portlet container driver does not work when appserver is installed into folde...
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Tools bundle
6.x
Macintosh All
: P2 (vote)
: 6.x
Assigned To: Yulia Novozhilova
issues@installer
RELNOTE
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-11 09:33 UTC by Tomas Danek
Modified: 2009-09-23 11:12 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2009-09-11 09:33:33 UTC
- downloaded java-tools-bundle-update7-macosx-x86.dmg (6.7.1. bundle) build from smetiste
- installed both ide and appserver into default locations
- started ide and started GF using IDE
- http://localhost:8080/portletdriver/dt works

- uninstalled everything
- installed both ide and appserver into folder with space in path (/Users/tomas/space in path/SUNWappserver)
- started ide and started GF using IDE
- http://localhost:8080/portletdriver/dt does not work, server returns 404.


reproduced the same also on opensolaris. no root/user combination during installation/running was involved.
Comment 1 Alexei Mokeev 2009-09-11 10:50:49 UTC
Spaces in path are not supported by Application Platform SDK itself. We can update the installation instructions:

From:
---
Note: The installation directory must be empty, and the user profile you are using to run the installer must have
read/write permissions for this directory.
---

To:
---
Note: The installation directory must be empty, doesn't contain spaces and the user profile you are using to run the
installer must have read/write permissions for this directory.
---
Comment 2 Yulia Novozhilova 2009-09-18 10:58:26 UTC
Fixed in main:
 http://hg.netbeans.org/main-silver?cmd=changeset;node=73efaeac1891
Comment 3 Yulia Novozhilova 2009-09-18 12:15:12 UTC
Reopen to reassign
Comment 4 Yulia Novozhilova 2009-09-18 12:17:16 UTC
Fixed
Comment 5 Quality Engineering 2009-09-18 22:29:07 UTC
Integrated into 'main-golden', will be available in build *200909181401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/73efaeac1891
User: Yulia Novozhilova <ynov@netbeans.org>
Log: Fix #172006 Space in path
Comment 6 Yulia Novozhilova 2009-09-23 10:48:47 UTC
The fix was rolled back because it was unsafe. Trying to find better fix.
Comment 7 Yulia Novozhilova 2009-09-23 11:12:14 UTC
Wrong issue. last comment was about #172000.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo