Bug 171752 - [68cat] Ad-hoc project group loses track of renamed/moved project
[68cat] Ad-hoc project group loses track of renamed/moved project
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
PC Linux
: P4 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
: NETFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-08 21:09 UTC by dynamite
Modified: 2016-07-07 08:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dynamite 2009-09-08 21:09:17 UTC
[ BUILD # : 200909080527 ]
[ JDK VERSION : 1.6.* ]

I have a project group that I created to hold a specified project.  I
then renamed that project and checked the option that said that its
associated directory should also be renamed.  I switched to another
group and then back again and found that the project group was empty.
 The project has become disassociated with the group.

After a little digging I noticed that the project's properties file
under userdir/config/Preferences/org/netbeans/modules/projectui/group
had properties that still specified the old project name and
location.  These properties should be renamed as a part of the
project rename refactoring.  Additionally it would be consistent if
the project group was renamed to match the new project name.

I'd like to NetFIX [1] this bug. Is it possible? [1]
http://wiki.netbeans.org/NetFIX
Comment 1 Jesse Glick 2009-09-21 19:46:43 UTC
It would indeed be better if the org.netbeans.modules.project.ui.groups.AdHocGroup (I assume this is the type of group
you were using) tracked project renames/moves and updated its metadata accordingly. Tricky because there is no API for
listening to project renames/moves; DefaultProjectOperationsImplementation could provide a static event set which
AdHocGroup could add a static listener to (taking advantage of the projectui -> projectuiapi impl dep).

Renaming the project group is not a good idea; in general a group contains many projects.
Comment 2 Martin Balin 2016-07-07 08:39:21 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo