Bug 171724 - Debugger does not start - ValueError: invalid literal for int() with base 10
Debugger does not start - ValueError: invalid literal for int() with base 10
Status: RESOLVED DUPLICATE of bug 196842
Product: python
Classification: Unclassified
Component: Debugger
6.x
Macintosh (x86) Mac OS X
: P1 with 1 vote (vote)
: TBD
Assigned To: jymen
nbpythonqa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-08 15:23 UTC by samdeleu
Modified: 2011-03-31 10:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description samdeleu 2009-09-08 15:23:53 UTC
Installed the newest version of NB with the python plugin.
Use external python 2.6.2

When starting the debugger it connects to the socketb but fails with 

>>>hits = int(hits) 
>>>ValueError: invalid literal for int() with base 10

Added a print command in the jpydeamon.py file to have the value of hits and it seems to be an empty string

The full output:
>>>[LOG]PythonDebugger : overall Starting
[LOG]PythonDebugger.taskStarted : I am Starting a new Debugging Session ...
[LOG]This window is an interactive debugging context aware Python Shell 
[LOG]where you can enter python console commands while debugging 
>>>[stdout:]('SAMSAM', '', None, 'SAMSAM')Exception in thread MainThread:

Traceback (most recent call last):
  File "C:\MyPrograms\Python26\lib\threading.py", line 525, in __bootstrap_inner
    self.run()
c:\documents and settings\sdeleu\.netbeans\6.7\config\nbpython\debug\nbpythondebug\jpydaemon.py
args =  ['C:\\Documents and Settings\\sdeleu\\.netbeans\\6.7
\\config\\nbPython\\debug\\nbpythondebug\\jpydaemon.py', 'localhost', '29100']
localDebuggee= None
JPyDbg connecting  localhost  on in=  29100 /out= 29101
JPyDbgI0001 : connected to  localhost
  File "C:\Documents and Settings\sdeleu\.netbeans\6.7\config\nbPython\debug\nbpythondebug\jpydaemon.py", line 590, in 
run
    exec self._cmd in self._myglobals,self._mylocals
  File "<string>", line 1, in <module>
  File "C:/My Documents/20_Projects/PythonDebugTest/src/pythondebugtest.py", line 4, in <module>
    __author__="sdeleu"
  File "C:/My Documents/20_Projects/PythonDebugTest/src/pythondebugtest.py", line 4, in <module>
    __author__="sdeleu"
  File "C:\Documents and Settings\sdeleu\.netbeans\6.7\config\nbPython\debug\nbpythondebug\jpydaemon.py", line 724, in 
trace_dispatch
    self.dispatchLineAndBreak(mainDebugger, frame , lthread )
  File "C:\Documents and Settings\sdeleu\.netbeans\6.7\config\nbPython\debug\nbpythondebug\jpydaemon.py", line 604, in 
dispatchLineAndBreak
    lthread.additionalInfo.breakHere(frame,lthread)
  File "C:\Documents and Settings\sdeleu\.netbeans\6.7\config\nbPython\debug\nbpythondebug\jpydaemon.py", line 810, in 
breakHere
    while ( self.dbg.parseSubCommand(  self.dbg._connection.getNextDebuggerCommand() , frame , lthread ) == FREEZE ):
  File "C:\Documents and Settings\sdeleu\.netbeans\6.7\config\nbPython\debug\nbpythondebug\jpydaemon.py", line 1453, in 
parseSubCommand
    hits = int(hits)
ValueError: invalid literal for int() with base 10: ''

Debug session normal end
Comment 1 efadae 2009-11-30 10:21:01 UTC
Same problem in Snow Leopard/NB 6.8 Beta.  Possible duplicate of bug Bug 175116, including my details there.
Comment 2 billh 2010-11-26 16:20:07 UTC
Same problem NB 6.9.1, OS X 5.8, Python 2.5.1.
Comment 3 kenorb 2011-03-31 10:57:20 UTC

*** This bug has been marked as a duplicate of bug 196842 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo