Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171656 - ClassCastException: com.sun.tools.javac.code.Type$CapturedType cannot be cast to javax.lang.model.type.DeclaredType
ClassCastException: com.sun.tools.javac.code.Type$CapturedType cannot be cast...
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Hints
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 68patch1-verified
:
: 179211 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-07 17:47 UTC by matthies
Modified: 2010-01-25 08:51 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.16 KB, text/plain)
2009-09-07 17:47 UTC, matthies
Details
stacktrace (7.16 KB, text/plain)
2009-11-25 10:10 UTC, matthies
Details

Note You need to log in before you can comment on or make changes to this bug.
Description matthies 2009-09-07 17:47:23 UTC
Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Windows XP, 5.1, x86

User Comments:
squib: just browsing through the source code in the editor..



Stacktrace: 
java.lang.ClassCastException: com.sun.tools.javac.code.Type$CapturedType cannot be cast to javax.lang.model.type.DeclaredType
        at org.netbeans.modules.java.hints.CollectionRemove.run(CollectionRemove.java:141)
        at org.netbeans.modules.java.hints.infrastructure.HintsTask$ScannerImpl.runAndAdd(HintsTask.java:220)
        at org.netbeans.modules.java.hints.infrastructure.HintsTask$ScannerImpl.scan(HintsTask.java:245)
        at org.netbeans.modules.java.hints.infrastructure.HintsTask$ScannerImpl.scan(HintsTask.java:184)
        at com.sun.source.util.TreeScanner.visitUnary(TreeScanner.java:304)
        at com.sun.tools.javac.tree.JCTree$JCUnary.accept(JCTree.java:1513)
Comment 1 matthies 2009-09-07 17:47:28 UTC
Created attachment 87240 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-09-07 17:47:33 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=150875
Comment 3 Max Sauer 2009-09-08 13:21:22 UTC
Cannot reproduce this in recent trunk builds. From the stack trace, I'm not able to tell what is wrong. No occurrences from 6.8 -> Closing as worksforme. 
In case this issue will be encountered in the future, please reopen and provide recent stack trace.
Comment 4 Seto 2009-11-16 09:00:27 UTC
I don't think this bug has been fixed. I checked out the source of slipstream.dev.java.net. And the exception occurs when opening the ChannelGroup.java.
Comment 5 Seto 2009-11-16 09:02:21 UTC
And here's more information about the environment. I'm using the 6.8 beta. But it seems that this should be already fixed.
Comment 6 Dusan Balek 2009-11-23 02:52:54 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/b2b8d75c7239
Comment 7 Quality Engineering 2009-11-23 18:10:08 UTC
Integrated into 'main-golden', will be available in build *200911231619* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b2b8d75c7239
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #171656: ClassCastException: com.sun.tools.javac.code.Type$CapturedType cannot be cast to javax.lang.model.type.DeclaredType - fixed.
Comment 8 Seto 2009-11-23 22:44:11 UTC
I downloaded the /dev/nightly/latest/jnlp/org-netbeans-modules-java-hints/org-netbeans-modules-java-hints.jar. And I replaced it into the java3/modules. And the exception continues reporting.
Comment 9 Seto 2009-11-25 08:44:23 UTC
It works now. Thank you.
Comment 10 matthies 2009-11-25 10:10:00 UTC
Created attachment 91686 [details]
stacktrace
Comment 11 Jan Lahoda 2010-01-18 01:28:26 UTC
A NB6.8 patch candidate, IMO.
Comment 12 Jan Lahoda 2010-01-18 01:30:44 UTC
*** Bug 179211 has been marked as a duplicate of this bug. ***
Comment 13 Peter Pis 2010-01-19 03:14:58 UTC
Verified.
Comment 14 pgebauer 2010-01-19 07:54:26 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/b7c5a6efe25a


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo