Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171563 - [68cat] Code Completion dialog doesn't update with key events
[68cat] Code Completion dialog doesn't update with key events
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
6.x
PC Linux
: P3 (vote)
: 7.0
Assigned To: David Strupl
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-06 06:07 UTC by esmithbss
Modified: 2010-10-01 14:58 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-09-06 06:07:15 UTC
[ BUILD # : 2009040632 ]
[ JDK VERSION : 1.6.* ]

While editing a ruby library file, the code completion/hint dialog
popped up; however,  continued typing did not update the list with
additional filtering based on the keystrokes, nor did the dialog
vanish once the typed value could not be found within the code
completion/hint list.
Comment 1 esmithbss 2009-09-06 06:19:05 UTC
Reproduced using the following steps:

While typing, at the end of a class name, hit the period key.

While the "Scanning in progress" tip window is displayed, start typing and continue typing for a few keystrokes.

Once the dialog is displayed, backout the keystrokes up to, but not including the period.

Now type again.  The keystroke events don't appear to be processed after this.
Comment 2 Erno Mononen 2009-09-07 14:36:06 UTC
I wasn't able to reproduce, but based on the description it seems that the issue must be in the code completion 
infrastructure -> reassigning to CSL for further evaluation.
Comment 3 Vitezslav Stejskal 2009-09-08 13:09:24 UTC

*** This issue has been marked as a duplicate of 160940 ***
Comment 4 esmithbss 2009-12-03 23:40:40 UTC
This is not a duplicate of the erasing text issue #160940.

In this case, the code completion dialogs are not responding to specific keys when they are displayed.

In this case, I believe the error is that some mouse keys are not mapped by the code completion dialog properly.

This is most prevalent for me right now in Java EE Web applications.

In the JEEWeb situation, the code completion dialogs display very quickly; however, the back arrow key does not appear to be recognized as a cursor movement key when the dialogs are displayed.  As a result, the user must resort to hitting the ESC key to kill the dialogs before moving the cursor, or they must switch to a mouse to move the cursor.
Comment 5 David Strupl 2010-10-01 14:58:10 UTC
I have just tried in JavaScript --> works for me. Please reopen if still a problem but please specify steps I can perform to see the problem in my setup. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo