Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171542 - Navigation from the interface type to its implementation
Navigation from the interface type to its implementation
Status: RESOLVED DUPLICATE of bug 136532
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
All All
: P1 with 12 votes (vote)
: TBD
Assigned To: issues@editor
issues@editor
http://www.adam-bien.com/roller/abien...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-05 09:52 UTC by abien
Modified: 2009-09-07 10:31 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abien 2009-09-05 09:52:08 UTC
In Eclipse 3.5, if you click+ctrl / cmd on a reference to an interface type, it asks you, whether you would like to navigate to an implementation of this interface 
(and lists all choices), or just open the declaration. I miss similar functionality in NetBeans 6.8.
Comment 1 abien 2009-09-05 09:56:13 UTC
The activation of this feature would perfectly fit into ctrl+click as well.
Comment 2 tprochazka 2009-09-07 10:23:28 UTC
Already exist plugin which can do this: http://wiki.netbeans.org/JavaGoToImplementation

But much better would be direct ctrl+click funcionality.

And this isssue is duplication of issues: #148517, #168058, #136532, 
Comment 3 tprochazka 2009-09-07 10:24:31 UTC
Plugin on wiki page is maybe old version, better is use Update center!
Comment 4 Vitezslav Stejskal 2009-09-07 10:31:33 UTC

*** This issue has been marked as a duplicate of 136532 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo