Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171541 - toString method generation
toString method generation
Status: RESOLVED DUPLICATE of bug 60745
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P2 with 9 votes (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://www.adam-bien.com/roller/abien...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-05 09:46 UTC by abien
Modified: 2010-12-05 12:41 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abien 2009-09-05 09:46:41 UTC
I miss the generation of the toString method from alt+insert / ctrl + i popup. The toString method should include the class name, the attributes with names 
and values.
Comment 1 Max Sauer 2009-09-07 10:43:29 UTC
Yes, this could be done. In the meantime, you can use code completion to provide toString() stub:

toS|  //pipe stands for caret, select 'toString()'
Comment 2 simas 2009-09-09 14:40:43 UTC
Such a plugin is now available:
http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=21008
Comment 3 jaylogan 2010-12-05 12:41:43 UTC

*** This bug has been marked as a duplicate of bug 60745 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo