Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171466 - [68cat] Remove archetype catalog not working as expected
[68cat] Remove archetype catalog not working as expected
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-04 11:13 UTC by David Simonek
Modified: 2009-11-11 08:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Simonek 2009-09-04 11:13:23 UTC
Implement add and remove buttons in maven project wizard so that users can manipulate with archetype catalogs. This is
add-on to issue 154978.
Comment 1 karmagfa 2009-10-28 04:30:39 UTC
I am a 6.8 netcat participant. I was about to post a bug report for the remove button not working, when I found this RFE.

In the IDE, the remove button doesn't do what the user expect: The button is enabled when an archetype from the list
"Local Archetype Catalog" is selected, but pressing it doesn't do anything at all.

If the button was disabled, then this issue could be called an RFE. Since it is not the case, I mark it as a bug.
Comment 2 David Simonek 2009-10-29 08:59:01 UTC
OK, but then priority and summary has to be changed to reflect current state.

Btw what should be expected behavior? You should not be able to delete local archetype catalog, should you?
Comment 3 Milos Kleint 2009-10-29 10:32:22 UTC
the archetypes from the catalog should not have the remove button enabled. We do not delete them.
Comment 4 David Simonek 2009-11-11 08:23:30 UTC
fixed in ad25f2016224


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo