Bug 171384 - Need increase/decrease font button on tool bar
Need increase/decrease font button on tool bar
Status: RESOLVED DUPLICATE of bug 41807
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
All All
: P3 with 2 votes (vote)
: 7.1
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-03 10:46 UTC by bsbawa10
Modified: 2014-03-15 10:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Netbeans buttons needed on toolbar (1.03 KB, image/jpeg)
2009-09-03 10:49 UTC, bsbawa10
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bsbawa10 2009-09-03 10:46:16 UTC
Many developers using netbeans need Dynamic zoom button for fonts like in Notepad++ editor.  I cannot tell how many
developers I have met who want this feature. I am myself a teacher for Sun Microsystems and I teach using Netbeans and
use a projector. I have to change fonts many times but there is no button which can go in increasing the font size in
steps. You have to go to options menus and navigate to be able to change the fonts and then again to change them back.
Also Notepad++ allows fonts to be changed with ctrl+wheel , that will be even great.
Comment 1 bsbawa10 2009-09-03 10:49:23 UTC
Created attachment 87034 [details]
Netbeans buttons needed on toolbar
Comment 2 bsbawa10 2009-09-03 16:10:26 UTC
If anybody has used Notepad++ free editor. Perhaps you already know what I mean. It is the "plus" sign and the "minus"
sign on the toolbar which is needed which can increase the fonts in the editor or decrease them with ease.
Comment 3 Josh9813 2010-03-31 16:03:39 UTC
(In reply to comment #0)
> Many developers using netbeans need Dynamic zoom button for fonts like in
> Notepad++ editor.  I cannot tell how many
> developers I have met who want this feature. I am myself a teacher for Sun
> Microsystems and I teach using Netbeans and
> use a projector. I have to change fonts many times but there is no button which
> can go in increasing the font size in
> steps. You have to go to options menus and navigate to be able to change the
> fonts and then again to change them back.
> Also Notepad++ allows fonts to be changed with ctrl+wheel , that will be even
> great.

I agree with you completely as my professor in class has been having the same issue, it took me a long time to figure out how to get the font size larger for the projector. 
In Netbeans 6.8 under: 
Tools > 
 Options > 
  Fonts & Colors tab: Select All Languages (drop-down box) > 
  Choose Default under Category >
  Click on the small Font button (next to Monospaced 12) 
  Now change the font size before class to let’s say 24, this will not change the font size in other computer applications.
This is a temporary solution until Netbeans incorporates the eagerly awaited toolbar shortcut for font size.
Comment 4 phazei 2010-04-01 03:59:16 UTC
I hope some dynamic font setting is added soon.

Check this bug as well if you want this.
http://netbeans.org/bugzilla/show_bug.cgi?id=41807
Comment 5 Miloslav Metelka 2011-10-04 15:54:38 UTC
Both Ctrl+mouse-wheel work and the Tools->Options->Keymap (search for 'zoom' Text Zoom In/Out actions have a shortcut assigned.

*** This bug has been marked as a duplicate of bug 41807 ***
Comment 6 markiewb 2014-03-15 10:15:38 UTC
FYI: At http://plugins.netbeans.org/plugin/53555/?show=true I provide a plugin which adds the actions (zoom in/out/reset) to the editor toolbar.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo