Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171337 - Enter in PHP editor generates ~170 disk touches
Enter in PHP editor generates ~170 disk touches
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: rmatous
issues@php
: PERFORMANCE, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-02 16:57 UTC by Jaroslav Tulach
Modified: 2009-09-15 07:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Test to try the counting yourself (17.28 KB, patch)
2009-09-02 17:00 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2009-09-02 16:57:51 UTC
An enter in PHP Editor seems to generate 170 disk touches. This is slightly too much and deserves some elimination. 
More info at http://wiki.netbeans.org/FitnessWithoutTouches
Comment 1 Jaroslav Tulach 2009-09-02 17:00:00 UTC
Created attachment 86985 [details]
Test to try the counting yourself
Comment 2 rmatous 2009-09-10 07:23:36 UTC
http://hg.netbeans.org/web-main/rev/c9601e164cb4

Notes:
many touched files are files in userdir(not sources) - index, preferences
includes also UI gesture collector touches

Fixed:
- code containing include, require statements do not touch files until needed
- navigator doesn't use index any more
- hints may need index but getting PHPIndex involves disk touches even if index isn't used later - so lazy
Comment 3 Quality Engineering 2009-09-11 21:36:02 UTC
Integrated into 'main-golden', will be available in build *200909111401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c9601e164cb4
User: Radek Matous <rmatous@netbeans.org>
Log: performance improvements: minimize disk touches #171337, avoid index reading in structure scanner #171571, hints get index just in case if needed, model cached together with parser result ...
Comment 4 Jaroslav Tulach 2009-09-15 07:36:10 UTC
I can verify that the amount of touches is now down to ~32. The rest is caused by mercurial, DiffSideBar and 
CloneableEditor as described and tracked in issue 171330


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo