Bug 171310 - Conditional Breakpoints
Conditional Breakpoints
Status: RESOLVED DUPLICATE of bug 132066
Product: php
Classification: Unclassified
Component: Debugger
6.x
All Linux
: P3 with 1 vote (vote)
: TBD
Assigned To: Ondrej Brejla
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-02 09:58 UTC by oopman
Modified: 2011-07-28 11:37 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oopman 2009-09-02 09:58:55 UTC
While debugging some python in PyDev for Eclipse a few days ago I noticed something nice: Conditional breakpoints. 

The basic idea is a BP with an associated watch. The BP only halts execution if the associated watch evaluates to true.

It would be very nice if this feature was implemented in the PHP/NetBeans debugger.
Comment 1 Filip Zamboj 2010-09-15 12:29:58 UTC
batch reassigning
Comment 2 OndrejBrejla 2011-07-18 14:02:15 UTC

*** This bug has been marked as a duplicate of bug 132066 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo