Bug 171303 - Invoking Debug Main Project took 3061 ms.
Invoking Debug Main Project took 3061 ms.
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-02 07:39 UTC by jmichelberger
Modified: 2010-03-30 00:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (27.29 KB, bin/nps)
2009-09-02 07:40 UTC, jmichelberger
Details
nps snapshot (47.28 KB, bin/nps)
2009-09-13 14:32 UTC, jfarjona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jmichelberger 2009-09-02 07:39:58 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3829-on-090828)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows XP, 5.1, x86

User Comments:
GUEST: When starting Java web application in debug mode.


Maximum slowness yet reported was 35596 ms, average is 10378
Comment 1 jmichelberger 2009-09-02 07:40:04 UTC
Created attachment 86949 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-09-02 07:40:08 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=154609
Comment 3 Martin Entlicher 2009-09-02 11:02:42 UTC
Loading of classes takes time. Probably disk is busy.
Moving to ANT to evaluate if it can speed up something...
Comment 4 jfarjona 2009-09-13 14:32:02 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows Vista, 6.0, x86

User Comments: 
Running project.
Maximum slowness yet reported was 35596 ms, average is 11123
Comment 5 jfarjona 2009-09-13 14:32:08 UTC
Created attachment 87552 [details]
nps snapshot
Comment 6 Exceptions Reporter 2009-09-13 14:32:53 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=154609
Comment 7 Jesse Glick 2009-09-21 20:02:37 UTC
No idea why this is assigned to Ant.

First snapshot above is dupe of something already fixed in apisupport.project. Second is coming from
WebActionProvider.getTargetNames, which should probably run asynch.
Comment 8 David Konecny 2010-03-30 00:57:11 UTC
Likely fixed for 68 final release as all reports are from prior 68-final version.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo