Bug 171261 - Show proper category for actions registered by @EditorActionRegistration in Tools > Options > Keymap
Show proper category for actions registered by @EditorActionRegistration in T...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
All All
: P3 (vote)
: 8.2
Assigned To: markiewb
issues@editor
: API_REVIEW_FAST, NETFIX
Depends on:
Blocks: 258797
  Show dependency treegraph
 
Reported: 2009-09-01 14:25 UTC by Tomas Mysik
Modified: 2016-07-23 01:51 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2009-09-01 14:25:51 UTC
Steps to reproduce:
- create an action in Editors/text/x-php5/Actions
- open Tools > Options > Keymap -> this action is in "Other" category instead of "PHP" category

Thanks.

Product Version: NetBeans IDE Dev (Build 090901)
Java: 1.6.0_14; Java HotSpot(TM) 64-Bit Server VM 14.0-b16
System: Linux version 2.6.28-15-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 David Strupl 2012-10-25 13:39:09 UTC
Bug prior to 7.0, not touched for the last 2 years --> P4.
Comment 2 David Strupl 2012-10-26 13:07:44 UTC
Tomasi, is this still a problem?
Comment 3 Tomas Mysik 2012-10-26 13:44:39 UTC
Your issue, your responsibility.
Comment 4 Miloslav Metelka 2012-10-29 11:01:35 UTC
There is no PHP action's category (and there should not be).
Comment 5 Tomas Mysik 2012-10-29 11:27:22 UTC
Have you built PHP cluster? Since I can see PHP category and it is IMHO OK for PHP specific actions. Or am I wrong?

Thanks.
Comment 6 Ralph Ruijs 2016-04-26 17:39:27 UTC
Actions registered by EditorActionRegistration are all placed in category other instead of Editor. It would be great if the category can be set by the action, as requested in #258797
Comment 7 markiewb 2016-07-16 18:21:41 UTC
(In reply to Ralph Ruijs from comment #6)
> It would be great if the category can be set by the action, as requested in #258797

Fixed http://hg.netbeans.org/core-main/rev/6125092ec0c8

@Ralph: Could you have a look if the commit is correct? I am not sure about the base and implementation version.
Comment 8 Ralph Ruijs 2016-07-16 19:00:16 UTC
Nice fix, don't hesitate to take #258797 as well ;-)
Comment 9 Quality Engineering 2016-07-19 01:43:16 UTC
Integrated into 'main-silver', will be available in build *201607190002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/6125092ec0c8
User: Benno Markiewicz <markiewb@netbeans.org>
Log: #171261 - Show proper category for actions registered by @EditorActionRegistration in Tools > Options > Keymap
Comment 10 Jaroslav Tulach 2016-07-21 08:16:14 UTC
Adding API review attributes - post mortem. Change is compatible, tested, documented and versioning is OK. Great.
Comment 11 markiewb 2016-07-21 21:37:41 UTC
Fixed the layer-registration code. Incorrect path is now corrected.

I stumpled about this, when solving https://netbeans.org/bugzilla/show_bug.cgi?id=258797

The proper registration is documented at http://wiki.netbeans.org/DevFaqHowToDefineTheKeyMapCategoryForAnAction#Keymap_category_for_.40EditorActionRegistration

http://hg.netbeans.org/core-main/rev/0d1585f7e902
Comment 12 Quality Engineering 2016-07-23 01:51:43 UTC
Integrated into 'main-silver', will be available in build *201607230002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/0d1585f7e902
User: Benno Markiewicz <markiewb@netbeans.org>
Log: #171261 - Show proper category for actions registered by @EditorActionRegistration in Tools > Options > Keymap - fixed the layer registration

see http://wiki.netbeans.org/DevFaqHowToDefineTheKeyMapCategoryForAnAction#Keymap_category_for_.40EditorActionRegistration


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo