Bug 17125 - Result sets not displayed for stored procedures
Result sets not displayed for stored procedures
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
3.x
PC Windows 3.1/NT
: P3 with 1 vote (vote)
: 6.x
Assigned To: David Vancouvering
issues@db
:
: 127596 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 11:04 UTC by ats37
Modified: 2008-07-15 12:23 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ats37 2001-10-30 11:04:36 UTC
If I use the Execute Command window to run a SELECT statement, the results are 
displayed in the lower half of the window.  If I use it to execute a stored 
procedure that returns a result set, all I see is a dialog saying 'Command 
successfully executed' - the results are not displayed.  Since we have an audit 
requirement that all database access should be done through SPs, it's a major 
limitation not to be able to test them...
Comment 1 Radko Najman 2001-11-19 14:58:11 UTC
You are right. The results are displayed only for SELECT statements.
Stored procedures may return multiple result sets and the Execute
Command window isn't designed to display more then one result set.
(This window was originally designed to execute SELECT statements only
and the possibility to execute other kinds of SQL/DDL commands was
added later.)

We are working on new generation of the Database Explorer module which
should be able to display more result sets. This new module is based
on  different architecture and we write the module from the scratch.
That's why I changed the issue type from DEFECT to ENHANCEMENT - we
don't plan to add any new features to the current module. We don't
work on it any more and we fix the most critical bugs only.

What can I try to do is to display the results for stored procedures
which return a simple result set only. If you want to display the
results for stored procedures which return multiple result sets in the
current module you can try to modify the current implementation of the
Execute Command window and contribute it. It should not be difficult
(good starting point is
org.netbeans.modules.db.explorer.dataview.DataViewWindow class).
Comment 2 Jan Chalupa 2001-11-27 12:07:45 UTC
Target milestone -> 3.3.1.
Comment 3 Radko Najman 2001-12-04 10:30:21 UTC
Will be investigated for new module based on MDR.
Comment 4 Quality Engineering 2003-06-30 17:16:17 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 5 Quality Engineering 2003-06-30 17:17:27 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 6 Jan Chalupa 2003-10-30 12:06:33 UTC
A mistakenly closed RESOLVED LATER/REMIND issue. Reopening.
Comment 7 David Vancouvering 2007-05-29 22:27:10 UTC
I can't tell - is this working now for a single result set?
Comment 8 Andrei Badea 2007-05-30 10:35:57 UTC
Not sure and I don't have time to check it now. From a quick look at the code I
think it should work. Could you please try it? E.g. with a simple SP on Derby?
Thanks.
Comment 9 David Vancouvering 2007-05-30 21:12:25 UTC
Yes, I'll give it a try.
Comment 10 David Vancouvering 2008-02-18 08:24:25 UTC
*** Issue 127596 has been marked as a duplicate of this issue. ***
Comment 11 Roman Mostyka 2008-07-15 12:19:16 UTC
Fixed.
Comment 12 Roman Mostyka 2008-07-15 12:23:59 UTC
Verified with build 080714.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo