Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171153 - Support for running/debugging single test methods
Support for running/debugging single test methods
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P2 with 3 votes (vote)
: 7.0
Assigned To: David Konecny
issues@javaee
:
: 153558 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-31 10:35 UTC by pribyl
Modified: 2010-06-03 06:13 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pribyl 2009-08-31 10:35:41 UTC
In J2SE project there is a possibility to invoke "Run Again" or "Debug" on a single test method after running JUnit
tests (in Test Results window, right-clicking on a node representing test method).

However, this is not supported in Web Application (there is only "Go to Source" option)

I consulted this with guys from JUnit team and according to them, these actions are enabled if the project provides such
actions (run.single.method, debug.single.method) through ActionProvider implementation from the project's lookup.

Is there a chance to provide this in WebApplication action provider?
Comment 1 summersb 2009-09-24 16:06:03 UTC
This would be really helpful if you could right click on a test method in the source editor and run that method.  Having
to run the entire test file to be able to run one test method again is to time consuming
Comment 2 gregors 2010-01-06 08:13:59 UTC
It is absolutely necessary for test driven development with junit! I can't imagine that anybody is running always all tests into a test class just to rerun a single test method. The fix should be done as soon as possible. Is NetBeans really a professional development ide or is it just a student's playground?
Comment 3 Petr Jiricka 2010-01-10 12:17:23 UTC
I agree with changing from enhancement to defect (inconsistency is a usability bug), but P1 is not appropriate per the bug priority guidelines:
http://wiki.netbeans.org/BugPriorityGuidelines
Comment 4 David Konecny 2010-05-03 22:55:40 UTC
*** Bug 153558 has been marked as a duplicate of this bug. ***
Comment 5 David Konecny 2010-05-24 21:53:02 UTC
I'm requesting waiver. The fix will not be ready in time - I tried to sync handling of java specific targets in EE project types with J2SE project but there is simply too many differences. I would want to fix this by refactoring shared code into a common module so that it is maintained in one place for all project types. Alternative of keeping 3 project types in synch with J2SE project just does not work. Changes will be large rather then small and I would not recommend it for inclusion in 69 even if it was finished in time - there will be a risk of short term regression(s).
Comment 6 David Konecny 2010-05-31 23:50:51 UTC
Implementation in EE project types was synchronized with J2SE project.
0ba632e1fa3c
Comment 7 Quality Engineering 2010-06-03 06:13:35 UTC
Integrated into 'main-golden', will be available in build *201006030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0ba632e1fa3c
User: David Konecny <dkonecny@netbeans.org>
Log: Bug #171153 - Support for running/debugging single test methods


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo