Bug 171150 - Invoking Debug took 3824 ms.
Invoking Debug took 3824 ms.
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 173054 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-31 10:20 UTC by satyambdvp
Modified: 2009-09-29 09:50 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (22.52 KB, bin/nps)
2009-08-31 10:20 UTC, satyambdvp
Details
nps snapshot (22.52 KB, bin/nps)
2009-09-04 17:10 UTC, Exceptions Reporter
Details
nps snapshot (118.14 KB, bin/nps)
2009-09-18 18:14 UTC, Exceptions Reporter
Details
nps snapshot (96.16 KB, bin/nps)
2009-09-22 03:19 UTC, ijay
Details

Note You need to log in before you can comment on or make changes to this bug.
Description satyambdvp 2009-08-31 10:20:25 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows Vista, 6.0, x86

User Comments:
dreidmg: start server in debug mode


Maximum slowness yet reported was 8627 ms, average is 5202
Comment 1 satyambdvp 2009-08-31 10:20:30 UTC
Created attachment 86836 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-08-31 10:20:35 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155208
Comment 3 Exceptions Reporter 2009-09-04 17:09:57 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments: 

Maximum slowness yet reported was 8627 ms, average is 4947
Comment 4 Exceptions Reporter 2009-09-04 17:10:04 UTC
Created attachment 87134 [details]
nps snapshot
Comment 5 Exceptions Reporter 2009-09-04 17:10:09 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155208
Comment 6 Exceptions Reporter 2009-09-15 21:50:44 UTC
This issue already has 8 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155208
Comment 7 Exceptions Reporter 2009-09-16 16:01:45 UTC
This issue already has 9 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155208
Comment 8 Exceptions Reporter 2009-09-18 18:14:38 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) Client VM, 11.0-b12, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b25
OS: Windows Vista, 6.0, x86

User Comments: 

Maximum slowness yet reported was 192052 ms, average is 23277
Comment 9 Exceptions Reporter 2009-09-18 18:14:43 UTC
Created attachment 87931 [details]
nps snapshot
Comment 10 Exceptions Reporter 2009-09-18 18:14:49 UTC
This issue already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155208
Comment 11 ijay 2009-09-22 03:19:27 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.1-b02-90, Java(TM) SE Runtime Environment, 1.6.0_15-b03-219
OS: Mac OS X, 10.6.1, x86_64

User Comments: 

Maximum slowness yet reported was 192052 ms, average is 24902
Comment 12 ijay 2009-09-22 03:19:32 UTC
Created attachment 88064 [details]
nps snapshot
Comment 13 Exceptions Reporter 2009-09-22 03:19:37 UTC
This issue already has 11 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155208
Comment 14 Exceptions Reporter 2009-09-23 16:32:21 UTC
This issue already has 14 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=155208
Comment 15 David Konecny 2009-09-24 03:57:11 UTC
I'm removing fix of issue 51461 which is quit slow and is performed on each invocation of run/debug action. Fix done in
51461 is always executed but results are (because of typo in code) never actually used. It's been like that since
a54bc24dcb81 which is more than 2 years ago and nobody complained about experiencing issue 51461. With EE6 EJBs will be
most likely deployed in WAR files so likelyhood is getting even smaller.

This fix should partially fix the problem. 41da33aea2ce
Comment 16 Quality Engineering 2009-09-26 21:10:57 UTC
Integrated into 'main-golden', will be available in build *200909251401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/41da33aea2ce
User: David Konecny <dkonecny@netbeans.org>
Log: #171150 - removing code which is slow and because of typo made two years ago results are actually never used and nobody complained about it
Comment 17 David Konecny 2009-09-29 09:49:45 UTC
*** Issue 173054 has been marked as a duplicate of this issue. ***
Comment 18 David Konecny 2009-09-29 09:50:44 UTC
*** Issue 173054 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo