Bug 170823 - Build fails on Win32
Build fails on Win32
Status: RESOLVED WORKSFORME
Product: www
Classification: Unclassified
Component: Builds & Repositories
6.x
All Windows Vista
: P2 (vote)
: TBD
Assigned To: nbbuild-issues@ide
nbbuild-issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-24 15:58 UTC by t_h
Modified: 2009-08-25 16:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description t_h 2009-08-24 15:58:00 UTC
Build fails with java.lang.StackOverflowError. 
Last messages printed to console:

-verify-apichanges:

netbeans:
  [genlist] Generating information for Auto Update...
  [nbmerge] e:\work\hg\core-main\nbbuild\netbeans
  [nbmerge] builtmodules=[ide.ergonomics]
  [nbmerge] builttargets=[-jdk-pre-preinit, -jdk-preinit, -jdk-warn, -jdk-presetdef-basic, -jdk-default, -jdk-init, -loa
d-build-properties, -bootstrap, -download-all-extbins, bootstrap, init-module-list, -do-set-buildnumber, set-buildnumber
, init-tasks, init, all-ide.ergonomics]
    [touch] Creating e:\work\hg\core-main\nbbuild\netbeans\nb.cluster.ergonomics.built

create-license-summary:

BUILD FAILED
java.lang.StackOverflowError
        at java.io.Win32FileSystem.resolve(Win32FileSystem.java:237)
        at java.io.File.<init>(File.java:312)
        at org.netbeans.nbbuild.extlibs.CreateLicenseSummary.findBinaries(CreateLicenseSummary.java:298)
        at org.netbeans.nbbuild.extlibs.CreateLicenseSummary.findBinaries(CreateLicenseSummary.java:300)
        at org.netbeans.nbbuild.extlibs.CreateLicenseSummary.findBinaries(CreateLicenseSummary.java:300)
        at org.netbeans.nbbuild.extlibs.CreateLicenseSummary.findBinaries(CreateLicenseSummary.java:300)
...
Comment 1 Jesse Glick 2009-08-24 17:55:10 UTC
Looks like you have some kind of symlink loop or similar in your source tree. Anyone else able to reproduce?
Comment 2 Quality Engineering 2009-08-25 07:36:50 UTC
Integrated into 'main-golden', will be available in build *200908250351* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6f375a79da36
User: Jesse Glick <jglick@netbeans.org>
Log: Diagnostics for #170823.
Comment 3 t_h 2009-08-25 16:18:14 UTC
The diagnostic message reveals: "#170823: possible loop in platform10/modules/modules/modules/modules/modules/modules/..."
In fact there was no loop but somehow a very deep directory hierarchy was created (over 1700 modules directory was
created). Probably somehow created during build and all subsequent builds were failing. It was rather complicated to
delete such directory (directory was valid but most commands and programs were unable to access it or delete it). Thanks
for help, feel free to close the issue. I have no idea how it was created, but after removal next build was finished
without any problem.
Comment 4 Jesse Glick 2009-08-25 16:44:48 UTC
OK. Obviously if you find out what created it, that would be a separate bug.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo