Bug 170634 - Netbeans deadlocks at startup while Scanning Projects
Netbeans deadlocks at startup while Scanning Projects
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@editor
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-19 16:00 UTC by schmidtm
Modified: 2009-09-09 14:40 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Scala Project, clean (9.53 KB, application/x-gzip)
2009-08-19 16:01 UTC, schmidtm
Details
Scala Editor Module (scala.editor as of today) from contrib, clean (208.04 KB, application/x-gzip)
2009-08-19 16:04 UTC, schmidtm
Details
NB Threaddump for Client VM (1.5.0_19-137) on Mac OSX 10.5.8 (10.70 KB, text/plain)
2009-08-19 16:05 UTC, schmidtm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schmidtm 2009-08-19 16:00:48 UTC
I have a deadlock in NetBeans at startup time. These two threads deadlock (on 0x09e08b48):

"Parsing & Indexing Loop (090819)" prio=6 tid=0x010dcad0 nid=0xb03000 in Object.wait() [0xb4c9d000..0xb4c9dd90]
	at java.lang.Object.wait(Native Method)
	- waiting on <0x09e08b48> (a org.openide.util.RequestProcessor$Task)
	at java.lang.Object.wait(Object.java:474)
	at org.openide.util.Task.waitFinished(Task.java:130)
	- locked <0x09e08b48> (a org.openide.util.RequestProcessor$Task)

"Path Registry Request Processor" daemon prio=1 tid=0x010892b0 nid=0xaa6e00 in Object.wait() [0xb489b000..0xb489bd90]
	at java.lang.Object.wait(Native Method)
	- waiting on <0x09e08b48> (a org.openide.util.RequestProcessor$Task)
	at java.lang.Object.wait(Object.java:474)
	at org.openide.util.Task.waitFinished(Task.java:130)
	- locked <0x09e08b48> (a org.openide.util.RequestProcessor$Task)


 I've attached the threaddump and the two projects to (hopefully) reproduce this issue on your box.
Comment 1 schmidtm 2009-08-19 16:01:59 UTC
Created attachment 86467 [details]
Scala Project, clean
Comment 2 schmidtm 2009-08-19 16:04:16 UTC
Created attachment 86468 [details]
Scala Editor Module (scala.editor as of today) from contrib, clean
Comment 3 schmidtm 2009-08-19 16:05:58 UTC
Created attachment 86469 [details]
NB Threaddump for Client VM (1.5.0_19-137) on Mac OSX 10.5.8
Comment 4 Petr Dvorak 2009-08-19 17:11:51 UTC
NB info from user: "The build is trunk from 3 hours ago. Checkout of main and then ant clean && ant."
Comment 5 Jiri Prox 2009-08-20 11:45:49 UTC
I can reproduce it as well - starting from fresh userdir and opening j2se project
Comment 6 Jan Jancura 2009-08-20 12:56:18 UTC
>indexing
Comment 7 Vitezslav Stejskal 2009-08-20 14:48:27 UTC
This is kind of similar to issue #168734. The problem is that code that runs as part of the project opening calls
ParserManager.parse() (I'm not sure if this is actually legal to do), which blocks if scan is running. And the scan
waits for projects to open.
Comment 8 Tomas Zezula 2009-09-09 14:40:02 UTC
Fixed in jet-main: 2143554a0189


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo