Bug 170542 - project.license property ignored
project.license property ignored
Status: RESOLVED DUPLICATE of bug 167661
Product: php
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-18 12:39 UTC by marcosfadul
Modified: 2009-08-19 09:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marcosfadul 2009-08-18 12:39:29 UTC
In Product Version: NetBeans IDE 6.7.1 (Build 200907230101)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

When I add project.license=gplv3 in project.properties file, this property is ignored and the template keep on using the
default license.

All file exist and I even tryed with the standard apache license that comes with the NB 6.7.

I hope this is usefull.
Comment 1 Jesse Glick 2009-08-18 17:55:57 UTC
What type of project are you using? In a 6.8 dev build, I make a Java Class Library, open project.properties from the
Files tab, add

project.license=apache20

at the top, save, make a new Java Class, and it has the Apache 2.0 license at the top as expected. So please provide
complete steps to reproduce from scratch.
Comment 2 marcosfadul 2009-08-18 19:01:08 UTC
Sorry, I thought it was a general problem. I'm currently working only in PHP projects. 

I tryed creating a new JS Project and there seem everything ok; project.license worked as expected.
The problem seems to be for PHP projects only. I read some comments of people having the same problem in some articles
about this feature.
Comment 3 Milos Kleint 2009-08-19 07:08:45 UTC
reassigning to php support then
Comment 4 Tomas Mysik 2009-08-19 09:38:41 UTC
Fixed in 6.8.

Thanks for reporting.


*** This issue has been marked as a duplicate of 167661 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo