Bug 170445 - ide randomly deadlock (becomes unresponive and must be killed).
ide randomly deadlock (becomes unresponive and must be killed).
Status: RESOLVED DUPLICATE of bug 169717
Product: platform
Classification: Unclassified
Component: Text
6.x
PC Windows XP
: P2 with 1 vote (vote)
: 6.x
Assigned To: mslama
issues@platform
: RANDOM, THREAD
: 170140 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-17 08:57 UTC by mihai
Modified: 2009-08-24 09:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
the printscreen (80.93 KB, image/png)
2009-08-17 08:57 UTC, mihai
Details
the threads stack (46.40 KB, text/plain)
2009-08-17 08:58 UTC, mihai
Details
deadloc on double click on search result (stack) (44.87 KB, text/plain)
2009-08-18 09:36 UTC, mihai
Details
deadlock on double click on search result (printscreen) (87.98 KB, image/png)
2009-08-18 09:37 UTC, mihai
Details
deadlock 3 (103.56 KB, text/plain)
2009-08-18 13:13 UTC, mihai
Details
deadlock 3 (28.75 KB, image/png)
2009-08-18 13:14 UTC, mihai
Details
part 4 (47.79 KB, text/plain)
2009-08-18 14:31 UTC, mihai
Details
part 4 (69.09 KB, image/png)
2009-08-18 14:32 UTC, mihai
Details
deadlock 5 (46.93 KB, text/plain)
2009-08-18 14:41 UTC, mihai
Details
deadlock 5 (74.04 KB, image/png)
2009-08-18 14:42 UTC, mihai
Details
Another stack trace (17.25 KB, text/plain)
2009-08-19 14:12 UTC, mgoe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mihai 2009-08-17 08:57:24 UTC
The ide freeze and becomes unresponsive. 
This happen on NB 6.8 M1. All my projects are maven based. After the freeze the ide is not recovering and must be killed.
For the attached stacks and printscreen, the action that caused the lock was a double click (open) on a pom.xml
But i reproduced this also on closing an log4j.xml and on a right click on a project an the "properties".
I will continue to send updates (stacks/printscreens) as the issue is reproducing
Comment 1 mihai 2009-08-17 08:57:59 UTC
Created attachment 86303 [details]
the printscreen
Comment 2 mihai 2009-08-17 08:58:21 UTC
Created attachment 86304 [details]
the threads stack
Comment 3 Milos Kleint 2009-08-17 14:43:14 UTC
to me the problem thread seems to be this one, but it's not clear to mewhat NbEditorDocument waits for (no other thread
seems to have NbEditorDocument locked. Please evaluate

at java.lang.Object.wait(Native Method)
        - waiting on <0x14f5f458> (a org.netbeans.modules.editor.NbEditorDocument)
        at java.lang.Object.wait(Object.java:485)
        at javax.swing.text.AbstractDocument.readLock(AbstractDocument.java:1372)
        - locked <0x14f5f458> (a org.netbeans.modules.editor.NbEditorDocument)
        at org.netbeans.editor.BaseDocument.render(BaseDocument.java:1368)
        at org.openide.text.PositionRef$Manager$DocumentRenderer.render(PositionRef.java:889)
        at org.openide.text.PositionRef$Manager.processPositions(PositionRef.java:346)
        at org.openide.text.PositionRef$Manager.documentClosed(PositionRef.java:287)
        at org.openide.text.CloneableEditorSupport.doCloseDocument(CloneableEditorSupport.java:2142)
        at org.openide.text.CloneableEditorSupport.closeDocument(CloneableEditorSupport.java:2113)
        - locked <0x14f5f618> (a org.openide.windows.CloneableOpenSupport$Listener)
        at org.openide.text.CloneableEditorSupport.notifyClosed(CloneableEditorSupport.java:1985)
        at org.openide.text.DataEditorSupport.notifyClosed(DataEditorSupport.java:310)
        at org.netbeans.modules.xml.text.TextEditorSupport.notifyClosed(TextEditorSupport.java:216)
        at org.openide.text.CloneableEditorSupport.close(CloneableEditorSupport.java:2089)
        at org.openide.windows.CloneableOpenSupport.close(CloneableOpenSupport.java:126)
        at org.netbeans.modules.versioning.diff.DiffSidebar.getText(DiffSidebar.java:953)
        at org.netbeans.modules.versioning.diff.DiffSidebar.getText(DiffSidebar.java:852)
        at org.netbeans.modules.versioning.diff.DiffSidebar.access$900(DiffSidebar.java:98)
        at org.netbeans.modules.versioning.diff.DiffSidebar$RefreshDiffTask.fetchOriginalContent(DiffSidebar.java:816)
        at org.netbeans.modules.versioning.diff.DiffSidebar$RefreshDiffTask.computeDiff(DiffSidebar.java:787)
        at org.netbeans.modules.versioning.diff.DiffSidebar$RefreshDiffTask.run(DiffSidebar.java:777)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1070)

Comment 4 Milos Kleint 2009-08-17 14:44:47 UTC
*** Issue 170140 has been marked as a duplicate of this issue. ***
Comment 5 mihai 2009-08-18 09:35:34 UTC
Another deadlock. After a search in project(ctrl+shift+F), i double clicked on a search result. 
Comment 6 mihai 2009-08-18 09:36:28 UTC
Created attachment 86377 [details]
deadloc on double click on search result (stack)
Comment 7 mihai 2009-08-18 09:37:02 UTC
Created attachment 86378 [details]
deadlock on double click on search result (printscreen)
Comment 8 mihai 2009-08-18 09:48:49 UTC
I am using a custom look&feel OfficeLnFs_2.7.jar https://sourceforge.net/projects/officelnfs/files/
I hope this is not the cause of the problems.

my custom netbeans.conf nb options:
netbeans_default_options="-J-Dorg.netbeans.modules.tomcat.autoregister.token=1250073911712
-J-Dorg.netbeans.modules.tomcat.autoregister.catalinaHome=\"C:\Program Files\Apache Software Foundation\Apache Tomcat
6.0.20\" -J-client -J-Xss2m -J-Xms400m -J-Xmx400m -J-XX:PermSize=32m -J-XX:MaxPermSize=256m -J-Xverify:none
-J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dsun.java2d.noddraw=true
-J-Djava.net.preferIPv4Stack=true -J-Dsun.java2d.d3d=true --laf org.fife.plaf.VisualStudio2005.VisualStudio2005LookAndFeel" 
Comment 9 mihai 2009-08-18 13:13:09 UTC
This time the ide is not redrawing the ui.
Comment 10 mihai 2009-08-18 13:13:53 UTC
Created attachment 86389 [details]
deadlock 3
Comment 11 mihai 2009-08-18 13:14:11 UTC
Created attachment 86390 [details]
deadlock 3
Comment 12 mihai 2009-08-18 14:31:26 UTC
Another deadlock when opening an xml file. Attaching the part 4.
Comment 13 mihai 2009-08-18 14:31:49 UTC
Created attachment 86394 [details]
part 4
Comment 14 mihai 2009-08-18 14:32:06 UTC
Created attachment 86395 [details]
part 4
Comment 15 mihai 2009-08-18 14:41:12 UTC
Another one when closing a pom.xml editor window (after killing the ide with the part 4).
Comment 16 mihai 2009-08-18 14:41:44 UTC
Created attachment 86397 [details]
deadlock 5
Comment 17 mihai 2009-08-18 14:42:48 UTC
Created attachment 86398 [details]
deadlock 5
Comment 18 Vitezslav Stejskal 2009-08-18 14:50:12 UTC
IMO problem in CloneableEditorSupport. mihai please do not attach screenshots. They are not helpful in this particular
case. Threaddumps are good, thanks.
Comment 19 mgoe 2009-08-19 14:12:09 UTC
Created attachment 86454 [details]
Another stack trace
Comment 20 mslama 2009-08-24 09:11:25 UTC
Fixed in trunk already.

*** This issue has been marked as a duplicate of 169717 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo