Bug 170036 - Profiler slows down IDE startup
Profiler slows down IDE startup
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Tomas Hurka
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 11:59 UTC by Oleg Khokhlov
Modified: 2009-12-04 02:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Khokhlov 2009-08-07 11:59:09 UTC
happens after cold startup - reboot machine and start IDE (userdir exists)

  Product Version         = NetBeans IDE Dev (Build 200908070201) (#cb0dc77c69bf)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02; Sun Microsystems Inc.

from messages.log:
@15793 - ModuleInstall for org.netbeans.modules.java.kit called dT=0
@15793 - ModuleInstall for org.netbeans.modules.profiler.selector.ui/1 called dT=0
@19644 - ModuleInstall for org.netbeans.modules.profiler/1 called dT=3851
@19644 - ModuleInstall for org.netbeans.modules.profiler.oql.language/0 called dT=0
@19645 - ModuleInstall for org.netbeans.modules.welcome/1 called dT=1


on another machine it's even worse:
from messages.log:
@20111 - ModuleInstall for org.netbeans.modules.profiler.projectsupport called dT=0
@20111 - ModuleInstall for org.netbeans.modules.profiler.selector.spi/1 called dT=0
@20111 - ModuleInstall for org.netbeans.modules.profiler.selector.ui/1 called dT=0
@43656 - ModuleInstall for org.netbeans.modules.profiler/1 called dT=23545
@43656 - ModuleInstall for org.netbeans.modules.apisupport.ant called dT=0
@43656 - ModuleInstall for org.netbeans.modules.apisupport.project called dT=0
Comment 1 Tomas Hurka 2009-10-16 13:54:18 UTC
I am unable to reproduce it. I used after cold startup with existing userdir. See the log below:

Product Version: NetBeans IDE Dev (Build 200910151401)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 16.0-b06
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: C:\Documents and Settings\Administrator\.netbeans\dev

@5941 - ModuleInstall for org.netbeans.modules.profiler.selector.spi/1 called dT=0
@5942 - ModuleInstall for org.netbeans.modules.profiler.selector.ui/1 called dT=1
@6166 - ModuleInstall for org.netbeans.modules.profiler/1 called dT=224
@6166 - ModuleInstall for org.netbeans.modules.profiler.j2ee.sunas/1 called dT=0
@6166 - ModuleInstall for org.netbeans.libs.cglib/1 called dT=0

I will try different machine.
Comment 2 Jaroslav Tulach 2009-10-16 15:49:26 UTC
Can't you eliminate all work done in org.netbeans.modules.profiler/1? If the ModuleInstall is empty, then it does not 
matter how bad configuration of a computer is used to execute it.
Comment 3 Tomas Hurka 2009-11-11 05:37:13 UTC
I removed profiler initialization from restore() method. I would still like to know how you have got 23 seconds long initialization with the original code.

changeset:   152580:7a58d1f39b0b
user:        Tomas Hurka <thurka@netbeans.org>
date:        Wed Nov 11 13:35:02 2009 +0100
summary:     bugfix #170036, Profiler.getDefault() removed from restore(); profiler is initilaized lazily later


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo