Bug 169823 - IllegalArgumentException when create REST ws
IllegalArgumentException when create REST ws
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: REST
6.x
All Windows Vista
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-04 14:47 UTC by Jaroslav Pospisil
Modified: 2009-09-23 15:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2009-08-04 14:47:42 UTC
Build 200908040201,Win Wista,JDK 1.6.0_15
Create Java Web Web Application and Rest Service from Patterns (Singleton) in it.
IAE will be thrown into IDE,dissapears,but is still reported in IED Log (probable cause in SPACE_IN_PATH):

SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor
org.netbeans.modules.web.project.ui.WebLogicalViewProvider$WebLogicalViewRootNode$BrokenLinksAction
java.net.URISyntaxException: Illegal character in opaque part at index 20: jar:file:/C:/Program
Files/glassfish-v3-b57/glassfish/modules/asm-all-repackaged.jar!/
        at java.net.URI$Parser.fail(URI.java:2809)
        at java.net.URI$Parser.checkChars(URI.java:2982)
        at java.net.URI$Parser.parse(URI.java:3019)
        at java.net.URI.<init>(URI.java:578)
        at java.net.URI.create(URI.java:840)
Caused: java.lang.IllegalArgumentException
        at java.net.URI.create(URI.java:842)
        at org.netbeans.modules.project.libraries.ui.LibrariesModel.convertURLsToURIs(LibrariesModel.java:439)
        at org.netbeans.api.project.libraries.Library.getURIContent(Library.java:142)
        at org.netbeans.modules.java.project.BrokenReferencesModel.getReferences(BrokenReferencesModel.java:317)
        at org.netbeans.modules.java.project.BrokenReferencesModel.isBroken(BrokenReferencesModel.java:180)
        at org.netbeans.spi.java.project.support.ui.BrokenReferencesSupport.isBroken(BrokenReferencesSupport.java:115)
        at org.netbeans.modules.web.project.ui.WebLogicalViewProvider.hasBrokenLinks(WebLogicalViewProvider.java:278)
        at
org.netbeans.modules.web.project.ui.WebLogicalViewProvider$WebLogicalViewRootNode$BrokenLinksAction.run(WebLogicalViewProvider.java:502)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1070)
Caused: org.openide.util.RequestProcessor$SlowItem: task failed due to
        at org.openide.util.RequestProcessor$Task.schedule(RequestProcessor.java:655)
        at
org.netbeans.modules.web.project.ui.WebLogicalViewProvider$WebLogicalViewRootNode$BrokenLinksAction.refsMayChanged(WebLogicalViewProvider.java:523)
        at
org.netbeans.modules.web.project.ui.WebLogicalViewProvider$WebLogicalViewRootNode$BrokenLinksAction.propertyChange(WebLogicalViewProvider.java:493)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
        at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:878)
        at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:321)
        at org.openide.util.ChangeSupport.fireChange(ChangeSupport.java:130)
        at org.openide.util.ChangeSupport.fireChange(ChangeSupport.java:116)
        at org.netbeans.spi.project.support.ant.ProjectProperties$PP$2.run(ProjectProperties.java:349)
        at org.netbeans.spi.project.support.ant.ProjectProperties$PP$2.run(ProjectProperties.java:347)
        at org.openide.util.Mutex.readAccess(Mutex.java:285)
        at org.netbeans.spi.project.support.ant.ProjectProperties$PP.fireChange(ProjectProperties.java:355)
        at org.netbeans.spi.project.support.ant.ProjectProperties$PP.put(ProjectProperties.java:219)
        at org.netbeans.spi.project.support.ant.ProjectProperties.putProperties(ProjectProperties.java:128)
        at org.netbeans.spi.project.support.ant.AntProjectHelper$6.run(AntProjectHelper.java:734)
        at org.netbeans.spi.project.support.ant.AntProjectHelper$6.run(AntProjectHelper.java:732)
        at org.openide.util.Mutex.writeAccess(Mutex.java:394)
        at org.netbeans.spi.project.support.ant.AntProjectHelper.putProperties(AntProjectHelper.java:732)
        at org.netbeans.modules.java.api.common.classpath.ClassPathModifierSupport$3.run(ClassPathModifierSupport.java:280)
        at org.netbeans.modules.java.api.common.classpath.ClassPathModifierSupport$3.run(ClassPathModifierSupport.java:258)
        at org.openide.util.Mutex.writeAccess(Mutex.java:433)
        at
org.netbeans.modules.java.api.common.classpath.ClassPathModifierSupport.handleLibraryClassPathItems(ClassPathModifierSupport.java:257)
        at
org.netbeans.modules.java.api.common.classpath.ClassPathModifierSupport.handleLibraries(ClassPathModifierSupport.java:225)
        at org.netbeans.modules.java.api.common.classpath.ClassPathModifier.handleLibraries(ClassPathModifier.java:183)
        at org.netbeans.modules.java.api.common.classpath.ClassPathModifier.addLibraries(ClassPathModifier.java:179)
        at
org.netbeans.spi.java.project.classpath.ProjectClassPathModifierImplementation$Accessor.addLibraries(ProjectClassPathModifierImplementation.java:422)
        at org.netbeans.api.java.project.classpath.ProjectClassPathModifier.addLibraries(ProjectClassPathModifier.java:92)
        at org.netbeans.modules.websvc.rest.spi.RestSupport.addSwdpLibrary(RestSupport.java:464)
        at org.netbeans.modules.websvc.rest.projects.WebProjectRestSupport.addSwdpLibrary(WebProjectRestSupport.java:241)
        at
org.netbeans.modules.websvc.rest.projects.WebProjectRestSupport.ensureRestDevelopmentReady(WebProjectRestSupport.java:144)
        at org.netbeans.modules.websvc.rest.RestUtils.ensureRestDevelopmentReady(RestUtils.java:101)
        at org.netbeans.modules.websvc.rest.wizard.PatternResourcesIterator.instantiate(PatternResourcesIterator.java:83)
        at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1018)
        at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:588)
        at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:409)
        at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:248)
        at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:161)
        at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1527)
        at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1481)
        at org.openide.WizardDescriptor.access$1700(WizardDescriptor.java:127)
        at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:2052)
        at org.openide.WizardDescriptor$Listener$2.run(WizardDescriptor.java:2101)
        at org.openide.WizardDescriptor.lazyValidate(WizardDescriptor.java:1456)
        at org.openide.WizardDescriptor.access$1300(WizardDescriptor.java:127)
        at org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:2108)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:451)
        at $Proxy8.actionPerformed(Unknown Source)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
        at java.awt.Component.processMouseEvent(Component.java:6263)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
        at java.awt.Component.processEvent(Component.java:6028)
        at java.awt.Container.processEvent(Container.java:2041)
        at java.awt.Component.dispatchEventImpl(Component.java:4630)
        at java.awt.Container.dispatchEventImpl(Container.java:2099)
        at java.awt.Component.dispatchEvent(Component.java:4460)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
        at java.awt.Container.dispatchEventImpl(Container.java:2085)
        at java.awt.Window.dispatchEventImpl(Window.java:2475)
        at java.awt.Component.dispatchEvent(Component.java:4460)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
        at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:117)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
        at java.awt.Dialog$1.run(Dialog.java:1045)
        at java.awt.Dialog$3.run(Dialog.java:1097)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Dialog.show(Dialog.java:1095)
        at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:985)
        at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:1019)
        at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:1007)
        at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:115)
        at org.openide.util.Mutex.doEventAccess(Mutex.java:1355)
        at org.openide.util.Mutex.readAccess(Mutex.java:268)
        at org.netbeans.core.windows.services.NbPresenter.show(NbPresenter.java:992)
        at java.awt.Component.show(Component.java:1563)
        at java.awt.Component.setVisible(Component.java:1515)
        at java.awt.Window.setVisible(Window.java:841)
        at java.awt.Dialog.setVisible(Dialog.java:985)
        at org.openide.loaders.TemplateWizard.instantiateImpl(TemplateWizard.java:495)
        at org.openide.loaders.TemplateWizard.instantiate(TemplateWizard.java:374)
        at org.netbeans.modules.project.ui.actions.NewFile.doPerform(NewFile.java:154)
        at org.netbeans.modules.project.ui.actions.NewFile.access$200(NewFile.java:80)
        at org.netbeans.modules.project.ui.actions.NewFile$PopupListener.actionPerformed(NewFile.java:349)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
        at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
        at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
        at java.awt.Component.processMouseEvent(Component.java:6263)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
        at java.awt.Component.processEvent(Component.java:6028)
        at java.awt.Container.processEvent(Container.java:2041)
        at java.awt.Component.dispatchEventImpl(Component.java:4630)
        at java.awt.Container.dispatchEventImpl(Container.java:2099)
        at java.awt.Component.dispatchEvent(Component.java:4460)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
        at java.awt.Container.dispatchEventImpl(Container.java:2085)
        at java.awt.Window.dispatchEventImpl(Window.java:2475)
        at java.awt.Component.dispatchEvent(Component.java:4460)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
        at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:117)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
[catch] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
WARNING [org.netbeans.modules.j2ee.dd.impl.web.model_3_0.ServletMapping]: ServletMapping25.setUrlPattern() is only
fallback, use ServletMapping25.setUrlPatterns() instead!
Comment 1 Milan Kuchtiak 2009-08-04 16:36:41 UTC
Fixed:
http://hg.netbeans.org/main/rev/b588da1bfc96
Comment 2 Milan Kuchtiak 2009-08-04 16:42:33 UTC
Sorry, this is the right changeset:
http://hg.netbeans.org/main/rev/a9093ea3c0af
Comment 3 Milan Kuchtiak 2009-08-06 08:27:17 UTC
The issue is fixed.
Comment 4 Jaroslav Pospisil 2009-09-23 15:54:28 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo