Bug 169821 - Glassfish v3 missing when add a server to the "Servers" node
Glassfish v3 missing when add a server to the "Servers" node
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Pavel Flaska
issues@performance
: ERGONOMICS
: 169642 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-04 14:36 UTC by alexismp
Modified: 2009-08-06 17:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
List of available servers (68.66 KB, image/png)
2009-08-04 16:07 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alexismp 2009-08-04 14:36:54 UTC
Trying out 6.8 Milestone 1 on the Mac, the first think I did was to go to the "Add Server Instance" dialog to add a GlassFish v3 instance only to find that v1 and 
v2 were the only choices. Creating a Java EE application started the appropriate modules and did the trick but that felt a bit like jumping thru hoops.

Starting the proper Java EE modules when bringing up the "Add Server Instance" sounds like a good fix (IMHO of course).
Comment 1 Jaroslav Tulach 2009-08-04 16:06:33 UTC
My steps to reproduce:
1. start full IDE with empty user dir
2. show Services tab
3. right click servers node
4. choose "Add Server..."
A dialog is shown with a bunch of servers, but Glassfish V3 is missing.
Comment 2 Jaroslav Tulach 2009-08-04 16:07:17 UTC
Created attachment 85775 [details]
List of available servers
Comment 3 Jaroslav Tulach 2009-08-04 16:10:15 UTC
*** Issue 169642 has been marked as a duplicate of this issue. ***
Comment 4 Jaroslav Tulach 2009-08-04 16:10:43 UTC
Duplicate was P2.
Comment 5 Pavel Flaska 2009-08-05 11:40:51 UTC
it is not platform specific, reproducible on Linux platform too.
Comment 6 Pavel Flaska 2009-08-05 11:43:41 UTC
The bad thing is that our regression test does not catch the problem. Was there any change in GlassFish v3 (Prelude) registration?
Comment 7 Pavel Flaska 2009-08-05 12:30:07 UTC
dd1f49914899
Comment 8 Pavel Flaska 2009-08-05 15:48:07 UTC
Test updated and modified to prevent similar failures.

http://hg.netbeans.org/ergonomics/rev/5a7a9ec2adbe
Comment 9 Quality Engineering 2009-08-06 17:43:42 UTC
Integrated into 'main-golden', will be available in build *200908061401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dd1f49914899
User: Pavel Flaska <pflaska@netbeans.org>
Log: #169821: Uncommented displayName attribute to process instances when building ergonomics.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo