Bug 169613 - No way to rename Java EE servers
No way to rename Java EE servers
Status: RESOLVED DUPLICATE of bug 129071
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
All All
: P2 (vote)
: TBD
Assigned To: Petr Hejl
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-31 00:10 UTC by emiddio
Modified: 2013-09-04 13:02 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description emiddio 2009-07-31 00:10:50 UTC
after removing all file filters from tools/options/misc/files/Files Ingored By IDE
i can now see "most" filenames that begin with "." including both directory and filenames;

but i cannot see .nbattrs file in 67/config/J2EE/InstalledServers/

i want to edit the file from within netbeans -- to be safe i can use a different version of
netbeans with a different user directory to edit the file.

i need to edit the file to rename the name of my various servers without deleting and readding.
Comment 1 Jesse Glick 2009-07-31 15:31:36 UTC
.nbattrs files are always hidden, since they are interpreted as metadata by the filesystem layer. This will not be changed.

The real issue is that you felt the need to edit this file to begin with. The UI ought to provide some way to change the
server names, I guess.

Anyway the installed servers list should be updated to use NbPreferences, not the system filesystem. (It is possible to
read & convert the old format for compatibility.)
Comment 2 emiddio 2009-12-04 22:06:30 UTC
sorry -- after editing a bug report it brought this one up -- i thought it was
the same bug id -- it was not; i editied and committed before realizing not
the same bug report i had just submitted
Comment 3 Petr Hejl 2013-09-04 13:02:48 UTC

*** This bug has been marked as a duplicate of bug 129071 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo