Bug 169430 - DELETE instruction limited to the pager limit
DELETE instruction limited to the pager limit
Status: RESOLVED DUPLICATE of bug 168812
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
PC Windows Vista
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-29 10:23 UTC by neuros_nid
Modified: 2009-07-29 10:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description neuros_nid 2009-07-29 10:23:43 UTC
When clicking on "View Data" on a table, and executing an SQL instruction like "DELETE FROM 'table' WHERE field='foo'" 
(or even just "DELETE FROM 'table'"), only 20 elements are deleted. It seems limited to the "Page Size" value.

I'm working under an MSSQL database, and connecting using Microsoft JDBC driver 2.0 (I remember NB 6.5 behaved the 
same, with MS JDBC 1.0, 1.2).

Product Version: NetBeans IDE 6.7 (Build 200906241340)
Java: 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16
System: Windows Vista version 6.0 running on x86; Cp1252; fr_FR (nb)
Userdir: C:\Users\Degardin\.netbeans\6.7
Comment 1 Jiri Rechtacek 2009-07-29 10:29:35 UTC
I guess it's a duplicate of issue 168812. Already fixed in NB6.8. The fix should be a part of NB6.7 Patch1.

*** This issue has been marked as a duplicate of 168812 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo