Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 169394 - Error running debug test - "Null Test: Caused an ERROR"
Error running debug test - "Null Test: Caused an ERROR"
Status: RESOLVED INCOMPLETE
Product: java
Classification: Unclassified
Component: Compiler
7.2
PC Linux
: P2 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-28 22:42 UTC by neilg
Modified: 2014-03-28 08:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description neilg 2009-07-28 22:42:54 UTC
In a maven jar project I hit ctrl-shift-f6 to debug a test file, an error occurs running the test:

Testsuite: com.melessoftware.elemental.collections.ElementalTreeMapTest
Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec

Null Test:         Caused an ERROR
com.melessoftware.elemental.collections.ElementalTreeMapTest
java.lang.ClassNotFoundException: com.melessoftware.elemental.collections.ElementalTreeMapTest
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)

In the Test Results window the test com.melessoftware.elemental.collections.ElementalTreeMapTest has one sub entry:
"Unknown caused an ERROR (0.0 s)".

The target/test-classes/com/melessoftware/elemental/collections/ directory is empty, i.e. the test class has not been
compiled to the target directory. target/test-classes/.netbeans_automatic_build exists with timestamp of 2009-07-28
22:25, target/.netbeans_CoS_timestamp_test and target/.netbeans_CoS_timestamp_test exist, both with timestamp 2009-07-28
22:26.
Comment 1 neilg 2009-07-28 22:49:21 UTC
I should mention, I'm using NB 6.7.1 rather than 6.7, but it's not available as an option in the version list.

I have built the project by pressing F11. The
target/test-classes/com/melessoftware/elemental/collections/ElementalTreeMapTest.class file exists.

Then when I press ctrl-shift-f6 to debug the test it is deleted and the test fails. Raising to P1 as it looks like debug
test does not work at all for a fairly simple maven project setup.
Comment 2 Jan Lahoda 2009-07-30 06:11:01 UTC
The only way I was able to reproduce similar problem so far, was by using a userdir created by a development version of
the IDE to run the 6.7.1 version of the IDE. The root cause of the problem in this case was issue #166489 (IDE internal
caches are not correctly updated when the version of the cache is changed). Are you using the same userdir to run
development/trunk builds of the IDE and to run 6.7.1? If yes, please delete ${userdir}/var/cache/index to fix the
problem. The cache should be the same for 6.7 and 6.7.1.

If you were not using development builds, could you please provide a simple reproducible test case? Also, could you
please check whether the correct classes are in the IDE's cache? Go to ${userdir}/var/cache/index (${userdir} is
${HOME}/.netbeans/6.7 by default), take a look into the "segments" file to find the "s<number>" directory that
corresponds to your source root, and then check whether directory "s<number>/java/13/classes" contains correct class files.

Thank you.
Comment 3 Peter Pis 2009-09-17 15:10:49 UTC
Without requested information for long time - INVALID. We can't do anything in this case. Reporter, please add requested
information and reopen issue. Thanks in advance.
Comment 4 marcincinik 2012-10-23 09:13:29 UTC
The same issue again

Unknown cause an ERROR (0,0 s)
I have multi-module maven project and using maven surefire and JUnit+DBUnit. I cannot send you the project, but the problem is there. I have no special or fancy configuration for maven-surefire - it's as straight at it is.

The only thing I see in the log files is
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri socket://localhost:1099

But I think it's not related to junit
Comment 5 Dusan Balek 2012-10-23 12:13:34 UTC
Could you please provide a simple reproducible test case? Thanks.
Comment 6 lucb1e 2014-03-26 13:41:12 UTC
Got the same problem with Netbeans 7.4. The problem randomly appears and disappears. Seems to have something to do with either debugging, breakpoints and/or Dropbox syncing when multiple people have the same project opened on multiple computers. I cannot (yet?) find any steps which consistently makes it appear or disappear.
Comment 7 Dusan Balek 2014-03-28 08:28:54 UTC
Hard to do anything without a reproducible test case. Sorry.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo