Bug 169284 - 4s in directory chooser
4s in directory chooser
Status: RESOLVED DUPLICATE of bug 169303
Product: platform
Classification: Unclassified
Component: Directory Chooser
6.x
All All
: P4 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE, RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-28 07:39 UTC by Jindrich Sedek
Modified: 2009-09-15 11:06 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (12.14 KB, bin/nps)
2009-07-28 07:39 UTC, Jindrich Sedek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-07-28 07:39:48 UTC
Build: NetBeans IDE Dev (Build 200907280201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.11, x86

User Comments:
jsedek: I pressed Open Project button on toolbar, UI got blocked for few seconds


Maximum slowness yet reported was 3057 ms, average is 3057
Comment 1 Jindrich Sedek 2009-07-28 07:39:53 UTC
Created attachment 85293 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2009-08-12 15:59:47 UTC
The most recent report http://statistics.netbeans.org/exceptions/exception.do?id=242262 shows 4s delay in 
DirectoryChooser. One idea that could improve the situation is to use FixedHeightLayoutCache. Possible?

java.beans.PropertyChangeSupport.firePropertyChange(): 4087 / 0
javax.swing.plaf.basic.BasicTreeUI$Handler.propertyChange(): 4087 / 0
javax.swing.plaf.basic.BasicTreeUI.setModel(): 4087 / 0
javax.swing.tree.VariableHeightLayoutCache.setModel(): 4087 / 0
javax.swing.tree.VariableHeightLayoutCache.rebuild(): 4087 / 0
javax.swing.tree.VariableHeightLayoutCache$TreeStateNode.expand(): 4087 / 0
javax.swing.tree.VariableHeightLayoutCache$TreeStateNode.expand(): 4087 / 0
    javax.swing.tree.VariableHeightLayoutCache$TreeStateNode.updatePreferredSize(): 4075 / 0
    javax.swing.tree.AbstractLayoutCache.getNodeDimensions(): 4075 / 26
        javax.swing.plaf.basic.BasicTreeUI$NodeDimensionsHandler.getNodeDimensions(): 4048 / 0
        org.netbeans.swing.dirchooser.DirectoryChooserUI$DirectoryTreeRenderer.getTreeCellRendererComponent(): 4048 / 
0
            org.netbeans.swing.dirchooser.DirectoryChooserUI$DirectoryTreeRenderer.getNodeIcon(): 3991 / 0
Comment 3 David Simonek 2009-08-12 16:22:17 UTC
I don't know, I never used FixedHeightLayoutCache. And I never saw such slowness even on very big folders (nb repo)
myself, so I assume this is low priority.
Comment 4 Tomas Pavek 2009-09-15 11:06:18 UTC

*** This issue has been marked as a duplicate of 169303 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo