Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 169146 - Installation Failure
Installation Failure
Status: RESOLVED INVALID
Product: installer
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: issues@installer
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-24 17:39 UTC by grpace
Modified: 2009-07-24 18:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grpace 2009-07-24 17:39:35 UTC
Hi!

Just downloaded NB 6.7 w/ PHP.
However the installation fails.

At about 30% install, the process shows:
Update CRC sums for update tracking file...
Then a roll-back starts.

The log file has the following entries:
----------
[2009-07-24 10:56:53.218]:         ... check if correct CRC sums are used in update_tracking file
D:\NetBeans\platform10\update_tracking\org-netbeans-modules-javahelp.xml
[2009-07-24 10:57:33.750]:         java.io.IOException: Data error (cyclic redundancy check)
[2009-07-24 10:57:33.750]:         	at java.io.FileInputStream.readBytes(Native Method)
[2009-07-24 10:57:33.750]:         	at java.io.FileInputStream.read(Unknown Source)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.utils.FileUtils.getCrc32(FileUtils.java:391)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.utils.FileUtils.getCrc32(FileUtils.java:378)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.utils.applications.NetBeansUtils.updateTrackingFilesCRC(NetBeansUtils.java:228)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.utils.applications.NetBeansUtils.updateTrackingFilesInfo(NetBeansUtils.java:209)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.products.nb.base.ConfigurationLogic.install(ConfigurationLogic.java:128)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.product.components.Product.install(Product.java:343)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:152)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:120)
[2009-07-24 10:57:33.750]:         org.netbeans.installer.utils.exceptions.InstallationException: Cannot update CRC sums
of update tracking files
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.products.nb.base.ConfigurationLogic.install(ConfigurationLogic.java:130)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.product.components.Product.install(Product.java:343)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:152)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:120)
[2009-07-24 10:57:33.750]:         Caused by: java.io.IOException: Can`t update CRC in update_tracking files
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.utils.applications.NetBeansUtils.updateTrackingFilesCRC(NetBeansUtils.java:254)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.utils.applications.NetBeansUtils.updateTrackingFilesInfo(NetBeansUtils.java:209)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.products.nb.base.ConfigurationLogic.install(ConfigurationLogic.java:128)
[2009-07-24 10:57:33.750]:         	... 3 more
[2009-07-24 10:57:33.750]:         Caused by: java.io.IOException: Data error (cyclic redundancy check)
[2009-07-24 10:57:33.750]:         	at java.io.FileInputStream.readBytes(Native Method)
[2009-07-24 10:57:33.750]:         	at java.io.FileInputStream.read(Unknown Source)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.utils.FileUtils.getCrc32(FileUtils.java:391)
[2009-07-24 10:57:33.750]:         	at org.netbeans.installer.utils.FileUtils.getCrc32(FileUtils.java:378)
[2009-07-24 10:57:33.750]:         	at
org.netbeans.installer.utils.applications.NetBeansUtils.updateTrackingFilesCRC(NetBeansUtils.java:228)
[2009-07-24 10:57:33.750]:         	... 5 more
[2009-07-24 10:57:33.750]:         Start rollback of Base IDE(nb-base/6.7.0.0.0)
[2009-07-24 10:57:33.750]:             ... running uninstallation logic
[2009-07-24 10:57:33.921]:             deleting file: C:\Documents and Settings\Gregory Pace\Start
Menu\Programs\NetBeans\NetBeans IDE 6.7.lnk
[2009-07-24 10:57:33.921]:                 ... file does not exist
[2009-07-24 10:57:33.921]:             deleting file: C:\Documents and Settings\Gregory Pace\Start Menu\Programs\NetBeans
[2009-07-24 10:57:33.921]:                 ... file does not exist
[2009-07-24 10:57:33.984]:             deleting file: C:\Documents and Settings\Gregory Pace\Desktop\NetBeans IDE 6.7.lnk
[2009-07-24 10:57:33.984]:                 ... file does not exist
[2009-07-24 10:57:33.984]:             ... deleting installed files
----------

I have downloaded the installer twice thinking the download may have been buggy, but to no avil.

Please advise/help.

Respectfully,
Greg Pace
Comment 1 dlipin 2009-07-24 18:01:59 UTC
You hard disk drive is likely dying. The "Data error (cyclic redundancy check)" means that you have bad sectors.
Try install to other disk (C:\, for example) or flash drive.
Don`t forget to run Check Disk utility against disk D.

This have nothing related to installer - nor to Java. It`s just the HDD issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo