Bug 169098 - AWT thread blocked for 31151 ms.
AWT thread blocked for 31151 ms.
Status: VERIFIED WORKSFORME
Product: javaee
Classification: Unclassified
Component: Hibernate
6.x
All All
: P3 (vote)
: TBD
Assigned To: Petr Cyhelsky
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-24 10:34 UTC by Jindrich Sedek
Modified: 2010-01-11 07:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (14.94 KB, bin/nps)
2009-07-24 10:34 UTC, Jindrich Sedek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-07-24 10:34:33 UTC
Build: NetBeans IDE Dev (Build 200907240201)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.27.25-170.2.72.fc10.x86_64, amd64

User Comments:
jsedek: Create new WebApplication
invoke project properties
select Frameworks
add Hibernate
press "ok" to close project properties


Maximum slowness yet reported was 31151 ms, average is 31151
Comment 1 Jindrich Sedek 2009-07-24 10:34:39 UTC
Created attachment 85164 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2009-07-24 15:44:16 UTC
Hibernate framework's extend() method needs ProjectMutex.writeAccess, which may not be available for those 31s...
Comment 3 Petr Cyhelsky 2009-09-08 09:57:18 UTC
I'm unable to reproduce and sadly in this case the snapshot doesn't help much(but i don't think ProjectMutex.writeAccess
is involved as there would be some thread which would be running for the duration which there isn't - it seems more
likely to me that the culprit is some of the native calls ). It would be great if it occurred again in newer build with
new snapshot format...  until then closing as worksforme.
Comment 4 Jindrich Sedek 2010-01-11 07:09:40 UTC
v


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo