Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168937 - The IDE cannot install modules even though they are available in update/download directory.
The IDE cannot install modules even though they are available in update/downl...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
67patch1-fixed
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 23:22 UTC by pgebauer
Modified: 2009-07-23 16:00 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (10.88 KB, text/plain)
2009-07-21 23:25 UTC, pgebauer
Details
NBMs are available but the IDE doesn't know it. (214.57 KB, image/jpeg)
2009-07-21 23:28 UTC, pgebauer
Details
Set of logs from a different attempt. (29.21 KB, text/plain)
2009-07-22 10:37 UTC, pgebauer
Details
Set of logs from a different attempt. (12.22 KB, text/plain)
2009-07-22 10:38 UTC, pgebauer
Details
Set of logs from a different attempt. (8.18 KB, text/plain)
2009-07-22 10:38 UTC, pgebauer
Details
log 1 (32.95 KB, text/plain)
2009-07-23 12:29 UTC, Andrei Chistiakov
Details
log 2 (5.08 KB, text/plain)
2009-07-23 12:30 UTC, Andrei Chistiakov
Details
log 3 (6.83 KB, text/plain)
2009-07-23 12:30 UTC, Andrei Chistiakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pgebauer 2009-07-21 23:22:57 UTC
1) install NB 6.7 java distro
2) register http://smetiste.czech.sun.com/builds/netbeans/6.7.1/fcs/2009-07-20_23-01-10/uc/catalog.xml.gz 
3) choose to install PHP, Ruby, C/C++ from available plugins tab

The IDE cannot install Ruby modules even though they are available in ruby2/update/download directory. Please see attachments.

If an user clicks on Exit button several times, the IDE will restart several times and it will run at the end.
If an user selects the radio button Restart IDE Later at the end of step 3) instaed of Restart IDE now, the issue will not appear.
Comment 1 pgebauer 2009-07-21 23:25:55 UTC
Created attachment 85041 [details]
messages.log
Comment 2 pgebauer 2009-07-21 23:28:01 UTC
Created attachment 85042 [details]
NBMs are available but the IDE doesn't know it.
Comment 3 Petr Blaha 2009-07-22 07:53:21 UTC
Upgrading the priority to P1.
Comment 4 dlipin 2009-07-22 10:11:48 UTC
Is it reproducible if you install Java distro without ergonomics (Feature on Demand in installer customization panel/
dialog) ?
Is it reproducible on Windows/Linux? 
Do you have "Force install into shared directories" checkbox enabled at Setting tab?

Please attach all the messages.log* files (messages.log.1, messages.log.2), not only the latest.
Comment 5 pgebauer 2009-07-22 10:37:41 UTC
Created attachment 85053 [details]
Set of logs from a different attempt.
Comment 6 pgebauer 2009-07-22 10:38:02 UTC
Created attachment 85054 [details]
Set of logs from a different attempt.
Comment 7 pgebauer 2009-07-22 10:38:28 UTC
Created attachment 85055 [details]
Set of logs from a different attempt.
Comment 8 pgebauer 2009-07-22 10:41:18 UTC
I'm sorry but I'm not avare of any Feature on Demand in installer customization panel/dialog on MacOS X.
User blaha reproduced the issue on Linux, I guess.
Comment 9 Marian Mirilovic 2009-07-22 11:29:15 UTC
Hi Dima, we discussed that recently with Yarda ... 
- reproducible only for Java distro (not JavaSE)
- after download feature : available in All IDE and not available in Java distro

Dima, are you able to fix it ? We discussed that with Yarda recently (I thought you are on vacation) and he is willing
to help us, but would live that on your shoulders if youy are back from vacation.
Comment 10 Marian Mirilovic 2009-07-22 11:42:59 UTC
... and here is the NPE from updater while restarting the IDE:

java.lang.NullPointerException
	at org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:833)
	at org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
	at org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
	at org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
Comment 11 Jaroslav Tulach 2009-07-22 12:42:38 UTC
The NPE is thrown while processing some Ruby NBMs:

n: nb_autospec_loader.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: nb_autotest_loader.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: nb_rspec_mediator.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: nb_suite_runner.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: nb_test_mediator.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: nb_test_runner.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: plugin.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: rake
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
n: rake_tasks_info.rb
n: sync-stdio.rb
 java.lang.NullPointerException
 org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:835)
 org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
 org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
 org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)
Comment 12 Jaroslav Tulach 2009-07-22 12:45:18 UTC
There is a Ruby NBM that contains files in root of ruby2 cluster and this is causing the NPE.
Comment 13 Jaroslav Tulach 2009-07-22 13:20:01 UTC
core-main#9f23832f7257

Fixed in trunk. Can be backported easily to release67_fixes by 
hg pull -r 9f23832f7257 http://hg.netbeans.org/core-main/
Comment 14 pgebauer 2009-07-22 15:33:34 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/9f23832f7257
Comment 15 Quality Engineering 2009-07-23 07:47:02 UTC
Integrated into 'main-golden', will be available in build *200907230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9f23832f7257
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #168937: Files in root of a cluster could cause NPE when regenerating config files
Comment 16 Andrei Chistiakov 2009-07-23 12:25:50 UTC
Product Version: NetBeans IDE 6.7 (Build 200906241340)
Java: 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

The issue is reproducible with build 2009-07-23_02-33-46, catalog URL:
http://smetiste.czech.sun.com/builds/netbeans/6.7.1/fcs/2009-07-23_02-33-46/uc/catalog.xml.gz as described in steps to
reproduce. Message logs are attached
Comment 17 Andrei Chistiakov 2009-07-23 12:29:34 UTC
Created attachment 85120 [details]
log 1
Comment 18 Andrei Chistiakov 2009-07-23 12:30:14 UTC
Created attachment 85121 [details]
log 2
Comment 19 Andrei Chistiakov 2009-07-23 12:30:29 UTC
Created attachment 85122 [details]
log 3
Comment 20 Petr Blaha 2009-07-23 12:39:31 UTC
This is different issue because there is the problem with dependencies now, see message.log:

 Warning - could not install some modules:
	org.netbeans.modules.ruby.kit - The module org.netbeans.modules.ruby.debugger would also need to be installed.
	org.netbeans.modules.ruby.debugger - The module org.netbeans.spi.debugger.ui was requested in version >= 2.16.2 but
only 2.16.1 was found.


Petr G. would you look on that?

Thanks,

Petr
Comment 21 Petr Blaha 2009-07-23 12:58:24 UTC
Alex, would you write steps and also which distro, NB version and also UC catalog did you use? I followed these steps
and didn't get any error message and the upgrade works fine:
1) install NB 6.7 Java All distro and start with new userdir
2) register this UC in IDE: http://smetiste.czech.sun.com/builds/netbeans/6.7.1/fcs/latest/uc/catalog.xml.gz 
3) install updates. This steps is required because this bug is fixed in updater module and must be updated before next steps
4) go to available modules tab and choose C/C++, PHP and Ruby and install without any error dialogs.

We need to find out what you did differently then me. Thanks
Comment 22 pgebauer 2009-07-23 13:55:18 UTC
If I don't skip the step "3) install updates.", the update will go smoothly. If I skip it, I will get errors regarding unavailability of new versions of some modules 
as it is mentioned above and I have to re-install the IDE.

I'm afraid, we will not be able to do anything with that.

Comment 23 Andrei Chistiakov 2009-07-23 13:58:17 UTC
I exactly followed the steps described by pgebauer with NB 6.7 'Java' distribution and did not install Auto Update UI
and Auto Update Services. Looks like that was the key difference.
On the other hand, nothing prevented me from choosing that way and some users can do the same.
Comment 24 Petr Blaha 2009-07-23 14:52:45 UTC
I understand your point but autoupdate module includes the fix that resolves the issue with Ruby module update. Only
users who have JavaAll distro and want to add Ruby will face this issue. This bug is already in NB 6.7 and nobody
reported this issue yet. The fix is resolved in new updater then you must install it in your IDE. Let's to summarize
when the issue will happen:

1) user has NB 6.7 JavaAll and wants to add Ruby. Usually, when users see update notification then they upgrade their
installation and after that the bug will be gone. I guess, just minimal percentage will ignore update and install Ruby
before.
2) NB 6.7.1 JavaAll users will not encounter this problem

Therefore, I would suggest to add item into RELEASE notes that describes what to do and release 6.7.1 with this.
 
Comment 25 Petr Blaha 2009-07-23 14:53:29 UTC
The bug is fixed.
Comment 26 Andrei Chistiakov 2009-07-23 16:00:26 UTC
Verified with UC catalog http://smetiste.czech.sun.com/builds/netbeans/6.7.1/fcs/2009-07-23_02-33-46/uc/catalog.xml.gz


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo