Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168890 - Watches window not updated
Watches window not updated
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
67patch1-verified
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 14:54 UTC by t_h
Modified: 2009-07-23 14:05 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description t_h 2009-07-21 14:54:40 UTC
I add boolean expression to watches. It changed its value from true to false between 2 breakpoints. Watches window
showed still true (both Variables window and Watches window), tool tip in editor showed correctly false.
Comment 1 Martin Entlicher 2009-07-21 16:48:16 UTC
It works just fine for me on a sample application like:

    public static void main(String[] args) {
        boolean bToWatch;
        bToWatch = true;
        bToWatch = true;
        bToWatch = false;
        bToWatch = false;
        bToWatch = true;
        bToWatch = false;
        bToWatch = true;
        bToWatch = false;
    }

where I've put breakpoint on each line and used Continue. "bToWatch" in Watches window was updated correctly.

Can you please provide more detailed information about what were you debugging and how can we reproduce it?
Comment 2 t_h 2009-07-22 13:44:39 UTC
Try this one a put breakpoint inside the loop. bToWatch stays true all the time (use Continue - F5, not Step over F8)

    public static void main(String[] args) {
        boolean bToWatch = true;
        for (int i = 0; i < 10; i++) {
            bToWatch = i % 2 == 0;
        }
    }
Comment 3 Martin Entlicher 2009-07-22 15:01:58 UTC
I've reproduced it in Build 200907161401, but in my local build it works O.K.
Comment 4 Martin Entlicher 2009-07-22 15:45:59 UTC
This is a regression caused by fix of issue #166016.
Comment 5 Martin Entlicher 2009-07-22 16:14:13 UTC
Fixed in changeset: c7fa3e8932d7
http://hg.netbeans.org/main/rev/c7fa3e8932d7

This should be pushed into release67_fixes, since this is a regression of fix of issue #166016, which was already
integrated into release67_fixes.
Comment 6 pgebauer 2009-07-22 16:30:32 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/acfce24c1399
Comment 7 Quality Engineering 2009-07-23 07:46:19 UTC
Integrated into 'main-golden', will be available in build *200907230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c7fa3e8932d7
User: mentlicher@netbeans.org
Log: #168890 - Correct the fix of issue #166016 - assure that PROP_STATE property is processed.
Comment 8 Vojtech Sigler 2009-07-23 14:05:31 UTC
Verified in Dev (Build 200907230201) as well as in 6.7.1 (Build 200907230233)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo