Bug 168855 - Support for branches and tags
Support for branches and tags
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P2 with 5 votes (vote)
: 7.1
Assigned To: issues@versioncontrol
issues@versioncontrol
: PLAN
: 181280 200701 206792 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 09:13 UTC by jsuchal
Modified: 2011-12-29 20:55 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jsuchal 2009-07-21 09:13:53 UTC
Hi, 

we are using branches on our project mercurial repository and there seems to be no way to switch branches, merge
branches. (Except using command line). Also a similar support for tags is lacking.

CVS versioning plugin seems to have "Tag..." and "Branches" menus that are exactly what I am looking for. Is this
planned in a future release?
Comment 1 jesselong 2009-07-27 14:46:01 UTC
Hi,

I'd like to add my voice in support of these features. Especially hg tag support. It is the only feature I miss when
using Mercurial in Netbeans.

Thanks,
Jesse
Comment 2 Ondrej Vrabec 2011-04-28 08:18:08 UTC
(In reply to comment #0)
> we are using branches on our project mercurial repository and there seems to be
> no way to switch branches, merge
> branches. (Except using command line).
There is, it's just the branches are labeled only with changeset id. To switch use Mercurial->Update and to merge Mercurial -> Merge

We should at least provide some basic support as project/revision annotations (display a tag/branch name next to a project name and in revision picker dialogs).
Comment 3 Tomas Stupka 2011-05-10 14:48:40 UTC
*** Bug 181280 has been marked as a duplicate of this bug. ***
Comment 4 Ondrej Vrabec 2011-06-23 10:03:08 UTC
fix: http://hg.netbeans.org/core-main/rev/c31dd374c138
Comment 5 Quality Engineering 2011-06-24 14:28:20 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/c31dd374c138
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #168855 - Support for branches and tags
switch branch action
Comment 6 Quality Engineering 2011-06-25 14:08:37 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/16480f05ee46
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #168855 - Support for branches and tags
project node annotations - display branch name and tags/shortened changeset id
Comment 7 Quality Engineering 2011-06-28 14:06:52 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/d64f8b35d0e5
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #168855 - Support for branches and tags
creat branch action
Comment 8 Ondrej Vrabec 2011-06-30 12:48:08 UTC
Marking as fixed. All relevant actions are available from Mercurial > Branch and Mercurial -> Tag.
Branches:
- create/close branch
- switch to branch
- label annotations on repository root/project nodes in views
Tags:
- create/delete tag
- manage tag dialog
Comment 9 Quality Engineering 2011-07-01 14:07:15 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/128c215798bc
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #168855 - Support for branches and tags
create tag action
Comment 10 Jesse Glick 2011-07-28 22:39:42 UTC
I was asked to give feedback on this feature, but

1. I rarely use tags, and never from within an IDE context.

2. Since I use the pbranch extension, the IDE's Create Branch and Close Branch actions are useless for me.

I tried Switch Branch a couple of times. It did what I expected. Still I would generally be using hg pmerge, not hg up, when moving from trunk to an experimental branch, so I only really tested switching to default. (Moving between release branches I do on occasion, but again, never in an IDE context.)
Comment 11 danielito 2011-07-29 12:17:51 UTC
I also tried the switch-branch feature and it works neatly.

Drawback: I cannot see on which branch I'm working in the file/project browser.
Comment 12 Ondrej Vrabec 2011-07-30 05:06:55 UTC
(In reply to comment #11)
> Drawback: I cannot see on which branch I'm working in the file/project browser.
It should be displayed on a project node. Ensure that View -> Show Versioning Labels is enabled. If still not displayed, file a separate bug.
Comment 13 Ondrej Vrabec 2011-08-05 14:50:18 UTC
*** Bug 200701 has been marked as a duplicate of this bug. ***
Comment 14 Ondrej Vrabec 2011-12-29 20:55:31 UTC
*** Bug 206792 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo