Bug 168780 - Need an API to change the current commit message
Need an API to change the current commit message
Status: VERIFIED DUPLICATE of bug 162279
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-19 13:40 UTC by Tim Lebedkov
Modified: 2009-09-13 10:33 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lebedkov 2009-07-19 13:40:01 UTC
For better integration with project management software it would be nice to be able to change the commit message that will 
appear next time the commit dialog is shown.
Comment 1 Tomas Stupka 2009-07-27 10:24:14 UTC
unfortunately, i'm not sure i understand what exactly you need. 
Could you please try to describe what and when do you want to do to the messages shown in the commit dlg?

thanks
Comment 2 Tim Lebedkov 2009-07-27 10:52:29 UTC
let's say I'm working on a task. I go to my issue management software and start a task there. I change the code and want
to commit it. I do "mercurial/commit". A dialog is shown. I'd like the message to be filled automatically by a plugin
with something like:

#34588: Fix the deadlock

Comment 3 Tomas Stupka 2009-07-27 11:03:16 UTC
1.) > For better integration with _project management software_
2.) > I go to my _issue management software_ ...
i'm still confused:) 
i guess that _project management software_ means the same as _issue management software_ in your second post. Are you
refering to the new bugzilla/jira integration in nb, or is it something else? have you seen the changes made in the
commit dlg in 6.7 - the "Update issue" section?
Comment 4 Tim Lebedkov 2009-07-27 13:28:25 UTC
I do not differentiate between _project management software_ and _issue management software_.

The extensions to the commit dialog in 6.7 are exactly what I need (it can do even more). Is there an API for this so I
can write a module supporting another _issue management software_? I was not able to find anything at
http://bits.netbeans.org/dev/javadoc/index.html. 

Is it enough to write a module like
http://hg.netbeans.org/release67/file/e524eaf6c766/bugzilla/src/org/netbeans/modules/bugzilla? Or does it have to be a
friend of something? If it does not, please close this issue.
Comment 5 Tomas Stupka 2009-07-27 13:36:44 UTC
there is no public api to do that 

*** This issue has been marked as a duplicate of 162279 ***
Comment 6 Tim Lebedkov 2009-09-13 10:33:07 UTC
-


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo