Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168626 - no executable location?
no executable location?
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
:
: 168848 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 16:17 UTC by Filip Zamboj
Modified: 2010-07-30 11:32 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE screenshot (189.13 KB, image/png)
2009-07-15 16:19 UTC, Filip Zamboj
Details
messags log (158.26 KB, text/plain)
2009-07-15 16:20 UTC, Filip Zamboj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2009-07-15 16:17:51 UTC
Product Version: NetBeans IDE 6.7.1 RC (Build 200907150227)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02

Some of my breakpoints are denoted as "No executable location available at line xx", Moreover one of breakpoints is not
highlighted after being hit. 

see attached picture. I'm on line 62 at the moment where breakpoint was hit. This is the output I got (there is line
number missing). As you can see in the picture it's not highlighted  at all. However, the thread is stopped, clearly. 
Method breakpoint hit in $Proxy110.add at line ? by thread httpSSLWorkerThread-8080-0.
Thread httpSSLWorkerThread-8080-0 stopped at $Proxy110.add - compiled without debug info.

3 breakpoints are denoted as being at no executable location. A session before they were hit as expected. 

1. run sample mave calculator service 
2. place breakpoints into CalculatorService.java to lines 62,66,68,71 and invoke debug project
3. add some numbers into web interface and you should stop on some of breakpoints. 
4. highlighting doesn't work at the first time 
5. some breakpoints are denoted as no executable locations after several debugging sessions without restarting IDE.
Debugger stops on them anyway. They are highlighted, 

showstopper for 6.7.1.
Comment 1 Filip Zamboj 2009-07-15 16:19:30 UTC
Created attachment 84791 [details]
IDE screenshot
Comment 2 Filip Zamboj 2009-07-15 16:20:33 UTC
Created attachment 84792 [details]
messags log
Comment 3 Filip Zamboj 2009-07-15 17:12:01 UTC
I reproduced in 67RC1 as well. Now hesitating ... is there something I missed? 
Comment 4 Filip Zamboj 2009-07-16 15:00:54 UTC
it showed up that this bug is reproducible only on first deploy to Glassfish, lowering to P3 because there is an obvious
workaround. 

workaround: restart debugger session 

i agree this is not a showstopper anymore. 
Comment 5 Daniel Prusa 2009-07-28 13:10:17 UTC
*** Issue 168848 has been marked as a duplicate of this issue. ***
Comment 6 Martin Entlicher 2010-07-30 11:32:36 UTC
This should be fixed also by the fix to issue #167250.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo